summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-22 08:31:01 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-22 08:31:01 +0000
commit1f6b77856b52eda30bb00b3c301b0cc6c546616a (patch)
treed339cc011092616595dbf9be7054e3529eeff9db /dev-python/pywebkitgtk
parentset packages purged, rm from package.mask (diff)
downloadgentoo-2-1f6b77856b52eda30bb00b3c301b0cc6c546616a.tar.gz
gentoo-2-1f6b77856b52eda30bb00b3c301b0cc6c546616a.tar.bz2
gentoo-2-1f6b77856b52eda30bb00b3c301b0cc6c546616a.zip
revbump, migrate -> python-r1
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pywebkitgtk')
-rw-r--r--dev-python/pywebkitgtk/ChangeLog7
-rw-r--r--dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/pywebkitgtk/ChangeLog b/dev-python/pywebkitgtk/ChangeLog
index bb9225965ddc..b9ed5e411c39 100644
--- a/dev-python/pywebkitgtk/ChangeLog
+++ b/dev-python/pywebkitgtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pywebkitgtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/ChangeLog,v 1.28 2013/03/17 17:58:25 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/ChangeLog,v 1.29 2013/06/22 08:31:01 idella4 Exp $
+
+*pywebkitgtk-1.1.8-r1 (22 Jun 2013)
+
+ 22 Jun 2013; Ian Delaney <idella4@gentoo.org> +pywebkitgtk-1.1.8-r1.ebuild:
+ revbump, migrate -> python-r1
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild b/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild
new file mode 100644
index 000000000000..5d90425d3f05
--- /dev/null
+++ b/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pywebkitgtk/pywebkitgtk-1.1.8-r1.ebuild,v 1.1 2013/06/22 08:31:01 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-r1
+
+DESCRIPTION="Python bindings for the WebKit GTK+ port"
+HOMEPAGE="http://code.google.com/p/pywebkitgtk/"
+SRC_URI="http://pywebkitgtk.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-libs/libxslt[${PYTHON_USEDEP}]
+ >=net-libs/webkit-gtk-1.1.15:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS MAINTAINERS NEWS README )
+
+python_configure_all() {
+ python_configure_all --disable-static
+}