summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-07-15 02:52:46 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-07-15 02:52:46 +0000
commit184b01bdd075ba7d61565458fde7a814d76d7b5d (patch)
tree71422e053a5ae2f6690b438ce230ed4b33ab41f8 /dev-python/rhpxl
parentwhitespace (diff)
downloadgentoo-2-184b01bdd075ba7d61565458fde7a814d76d7b5d.tar.gz
gentoo-2-184b01bdd075ba7d61565458fde7a814d76d7b5d.tar.bz2
gentoo-2-184b01bdd075ba7d61565458fde7a814d76d7b5d.zip
Detect server failure better, add RandR awareness to mode lists, fix resolution comparison, write Display subsections correctly, fall back to fbdev on ppc*, allow bigger resolutions, fix mode name splitting, autoconfig vmmouse driver for vmware/qemu.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'dev-python/rhpxl')
-rw-r--r--dev-python/rhpxl/ChangeLog12
-rw-r--r--dev-python/rhpxl/files/digest-rhpxl-0.473
-rw-r--r--dev-python/rhpxl/rhpxl-0.47.ebuild38
3 files changed, 51 insertions, 2 deletions
diff --git a/dev-python/rhpxl/ChangeLog b/dev-python/rhpxl/ChangeLog
index f748c007c02e..dddea8b51028 100644
--- a/dev-python/rhpxl/ChangeLog
+++ b/dev-python/rhpxl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/rhpxl
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpxl/ChangeLog,v 1.2 2006/09/07 05:54:56 dberkholz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpxl/ChangeLog,v 1.3 2007/07/15 02:52:46 dberkholz Exp $
+
+*rhpxl-0.47 (15 Jul 2007)
+
+ 15 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; +rhpxl-0.47.ebuild:
+ Detect server failure better, add RandR awareness to mode lists, fix
+ resolution comparison, write Display subsections correctly, fall back to
+ fbdev on ppc*, allow bigger resolutions, fix mode name splitting, autoconfig
+ vmmouse driver for vmware/qemu.
07 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+files/0.32-use-radeon-ddc.patch, rhpxl-0.32.ebuild:
diff --git a/dev-python/rhpxl/files/digest-rhpxl-0.47 b/dev-python/rhpxl/files/digest-rhpxl-0.47
new file mode 100644
index 000000000000..e5da3a4560ba
--- /dev/null
+++ b/dev-python/rhpxl/files/digest-rhpxl-0.47
@@ -0,0 +1,3 @@
+MD5 0640e066a740f0de41dc2949b7a03d2a rhpxl-0.47-2.fc8.src.rpm 110315
+RMD160 b5b0d3903a4656f180a284b87039aab041c52fca rhpxl-0.47-2.fc8.src.rpm 110315
+SHA256 094fb9743ed259876d6ac725c7d16e4475f642e642178c2df13d9301518564d7 rhpxl-0.47-2.fc8.src.rpm 110315
diff --git a/dev-python/rhpxl/rhpxl-0.47.ebuild b/dev-python/rhpxl/rhpxl-0.47.ebuild
new file mode 100644
index 000000000000..eb24c9af82ef
--- /dev/null
+++ b/dev-python/rhpxl/rhpxl-0.47.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rhpxl/rhpxl-0.47.ebuild,v 1.1 2007/07/15 02:52:46 dberkholz Exp $
+
+inherit eutils rpm
+
+# Tag for which Fedora Core version it's from
+FCVER="8"
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="2"
+
+DESCRIPTION="Python library for configuring and running X"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.fc${FCVER}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86 -s390"
+IUSE=""
+RDEPEND="dev-lang/python
+ >=dev-python/pyxf86config-0.3.31
+ dev-python/rhpl
+ dev-libs/newt
+ >=sys-apps/kudzu-1.2
+ x11-base/xorg-server
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/0.32-use-radeon-ddc.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}