summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-12-15 19:38:36 +0000
committerMike Gilbert <floppym@gentoo.org>2013-12-15 19:38:36 +0000
commitc69bba02f1ff49c291437950fa2e0de170496d32 (patch)
treeef63b07426d3c79c555671ee4dc3760da33e479b /dev-python/subunit
parentStable for sparc, wrt bug #493850 (diff)
downloadgentoo-2-c69bba02f1ff49c291437950fa2e0de170496d32.tar.gz
gentoo-2-c69bba02f1ff49c291437950fa2e0de170496d32.tar.bz2
gentoo-2-c69bba02f1ff49c291437950fa2e0de170496d32.zip
Make static libs optional.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/ChangeLog5
-rw-r--r--dev-python/subunit/subunit-0.0.16.ebuild8
2 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
index 7941b5fe4215..1cdc61f00694 100644
--- a/dev-python/subunit/ChangeLog
+++ b/dev-python/subunit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/subunit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.36 2013/12/15 01:51:46 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.37 2013/12/15 19:38:36 floppym Exp $
+
+ 15 Dec 2013; Mike Gilbert <floppym@gentoo.org> subunit-0.0.16.ebuild:
+ Make static libs optional.
15 Dec 2013; Mike Gilbert <floppym@gentoo.org> subunit-0.0.16.ebuild:
Adjust dependency on testtools, and make the tests work.
diff --git a/dev-python/subunit/subunit-0.0.16.ebuild b/dev-python/subunit/subunit-0.0.16.ebuild
index 35c954cd64fa..f2f2ed9887e1 100644
--- a/dev-python/subunit/subunit-0.0.16.ebuild
+++ b/dev-python/subunit/subunit-0.0.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.16.ebuild,v 1.2 2013/12/15 01:51:46 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.16.ebuild,v 1.3 2013/12/15 19:38:36 floppym Exp $
EAPI=5
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
#need to keyword the following in =dev-python/extras-0.0.3 then readd the keywords here
#ia64 s390 sh sparc amd64-fbsd
-IUSE=""
+IUSE="static-libs"
RDEPEND=">=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
dev-python/extras[${PYTHON_USEDEP}]"
@@ -28,10 +28,8 @@ DEPEND="${RDEPEND}
dev-util/cppunit
virtual/pkgconfig"
-DISTUTILS_IN_SOURCE_BUILD=1
-
src_configure() {
- econf
+ econf --enable-shared $(use_enable static-libs static)
distutils-r1_src_configure
}