summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2012-12-26 11:48:00 +0000
committerLars Wendler <polynomial-c@gentoo.org>2012-12-26 11:48:00 +0000
commitdf529471e08d9cceb48c8fe92012eb0226a0ed49 (patch)
treebd6362cf053bbc2d354557209f56e642cf4381de /dev-python/tagpy
parentmask USE suid (diff)
downloadgentoo-2-df529471e08d9cceb48c8fe92012eb0226a0ed49.tar.gz
gentoo-2-df529471e08d9cceb48c8fe92012eb0226a0ed49.tar.bz2
gentoo-2-df529471e08d9cceb48c8fe92012eb0226a0ed49.zip
Fixed compilation with ~media-libs/taglib-1.8 (bug #440740)
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'dev-python/tagpy')
-rw-r--r--dev-python/tagpy/ChangeLog7
-rw-r--r--dev-python/tagpy/files/tagpy-0.94.8-taglib-1.8_compat.patch29
-rw-r--r--dev-python/tagpy/tagpy-0.94.8-r1.ebuild7
3 files changed, 40 insertions, 3 deletions
diff --git a/dev-python/tagpy/ChangeLog b/dev-python/tagpy/ChangeLog
index 224017f28159..6efb80139638 100644
--- a/dev-python/tagpy/ChangeLog
+++ b/dev-python/tagpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/tagpy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/ChangeLog,v 1.50 2012/11/22 02:33:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/ChangeLog,v 1.51 2012/12/26 11:48:00 polynomial-c Exp $
+
+ 26 Dec 2012; Lars Wendler <polynomial-c@gentoo.org> tagpy-0.94.8-r1.ebuild,
+ +files/tagpy-0.94.8-taglib-1.8_compat.patch:
+ non-maintainer commit: Fixed compilation with ~media-libs/taglib-1.8 (bug
+ #440740).
22 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> -tagpy-0.94.8.ebuild:
Remove old version requiring boost that is no longer in tree.
diff --git a/dev-python/tagpy/files/tagpy-0.94.8-taglib-1.8_compat.patch b/dev-python/tagpy/files/tagpy-0.94.8-taglib-1.8_compat.patch
new file mode 100644
index 000000000000..084ea983a6d7
--- /dev/null
+++ b/dev-python/tagpy/files/tagpy-0.94.8-taglib-1.8_compat.patch
@@ -0,0 +1,29 @@
+https://github.com/inducer/tagpy/commit/d0759c0ec7d24ae8d1af395a1032521eb00b4d1f
+https://github.com/inducer/tagpy/commit/813ec4f03bb4411c7ffd15dcb3974da04a3f109c
+
+--- tagpy-0.94.8/src/wrapper/id3.cpp
++++ tagpy-0.94.8/src/wrapper/id3.cpp
+@@ -79,6 +79,10 @@
+ MF_OL(setVolumeAdjustment, 1, 2);
+ MF_OL(setPeakVolume, 1, 2);
+
++ #if (TAGPY_TAGLIB_HEX_VERSION >= 0x10800)
++ MF_OL(render, 0, 1)
++ #endif
++
+ // -------------------------------------------------------------
+ // MPEG
+ // -------------------------------------------------------------
+@@ -212,7 +216,11 @@
+ .DEF_SIMPLE_METHOD(removeFrame)
+ .DEF_SIMPLE_METHOD(removeFrames)
+
+- .DEF_SIMPLE_METHOD(render)
++ #if (TAGPY_TAGLIB_HEX_VERSION >= 0x10800)
++ .DEF_OVERLOADED_METHOD(render, ByteVector (cl::*)(int) const)
++ #else
++ .DEF_SIMPLE_METHOD(render)
++ #endif
+ ;
+ }
+
diff --git a/dev-python/tagpy/tagpy-0.94.8-r1.ebuild b/dev-python/tagpy/tagpy-0.94.8-r1.ebuild
index 5083de2542e1..a2e00d28e1ab 100644
--- a/dev-python/tagpy/tagpy-0.94.8-r1.ebuild
+++ b/dev-python/tagpy/tagpy-0.94.8-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/tagpy-0.94.8-r1.ebuild,v 1.9 2012/11/09 21:03:35 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tagpy/tagpy-0.94.8-r1.ebuild,v 1.10 2012/12/26 11:48:00 polynomial-c Exp $
EAPI="4"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.5 3.* *-jython 2.7-pypy-*"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Python Bindings for TagLib"
HOMEPAGE="http://mathema.tician.de//software/tagpy http://pypi.python.org/pypi/tagpy"
@@ -26,6 +26,9 @@ DEPEND="${RDEPEND}
DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
src_prepare() {
+ # bug #440740
+ epatch "${FILESDIR}"/${P}-taglib-1.8_compat.patch
+
# Disable broken check for Distribute.
sed -e "s/if 'distribute' not in setuptools.__file__:/if False:/" -i aksetup_helper.py