summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-13 06:23:16 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-13 06:23:16 +0000
commite21893521c868738da3db9e2c39cdfc993f2d664 (patch)
tree9c79465ddaa3025d87669dc5e9a73ca386f3f81e /dev-ruby/activesupport
parentmarked x86 per bug 404265 (diff)
downloadgentoo-2-e21893521c868738da3db9e2c39cdfc993f2d664.tar.gz
gentoo-2-e21893521c868738da3db9e2c39cdfc993f2d664.tar.bz2
gentoo-2-e21893521c868738da3db9e2c39cdfc993f2d664.zip
Version bump for Rails 3.2.6.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.2.6.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 42167cc0511c..75a321fb3266 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.171 2012/06/01 07:04:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.172 2012/06/13 06:23:16 graaff Exp $
+
+*activesupport-3.2.6 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activesupport-3.2.6.ebuild:
+ Version bump for Rails 3.2.6.
*activesupport-3.2.5 (01 Jun 2012)
diff --git a/dev-ruby/activesupport/activesupport-3.2.6.ebuild b/dev-ruby/activesupport/activesupport-3.2.6.ebuild
new file mode 100644
index 000000000000..36156f9bb011
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.2.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.2.6.ebuild,v 1.1 2012/06/13 06:23:16 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8
+ >=dev-ruby/multi_json-1.0
+ dev-ruby/i18n:0.6
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# libxml-ruby, nokogiri, and builder are not strictly needed, but there
+# are tests using this code.
+ruby_add_bdepend "test? (
+ virtual/ruby-test-unit
+ >=dev-ruby/libxml-2.0.0
+ dev-ruby/nokogiri
+ dev-ruby/builder:0
+ )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}