summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-07 12:06:39 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-07 12:06:39 +0000
commitb31223238671f40a8533fde2a59249e3c7deba6a (patch)
treefe661321af89e0162dcfac845de3df6d17e0f2b7 /dev-tcltk/tclxml/tclxml-2.4.ebuild
parentReomved possible dependency on dev-tcltk/tclxml-expat (diff)
downloadgentoo-2-b31223238671f40a8533fde2a59249e3c7deba6a.tar.gz
gentoo-2-b31223238671f40a8533fde2a59249e3c7deba6a.tar.bz2
gentoo-2-b31223238671f40a8533fde2a59249e3c7deba6a.zip
QA and removed old versions
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/tclxml/tclxml-2.4.ebuild')
-rw-r--r--dev-tcltk/tclxml/tclxml-2.4.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-tcltk/tclxml/tclxml-2.4.ebuild b/dev-tcltk/tclxml/tclxml-2.4.ebuild
index 4fbfa360dab6..58ac89fe3f61 100644
--- a/dev-tcltk/tclxml/tclxml-2.4.ebuild
+++ b/dev-tcltk/tclxml/tclxml-2.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.4.ebuild,v 1.18 2007/12/28 17:22:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.4.ebuild,v 1.19 2010/12/07 12:06:39 jlec Exp $
DESCRIPTION="Pure Tcl implementation of an XML parser."
HOMEPAGE="http://tclxml.sourceforge.net/"
@@ -9,25 +9,27 @@ IUSE=""
LICENSE="BSD"
SLOT="0"
KEYWORDS="x86 alpha sparc ~amd64"
+
DEPEND=">=dev-lang/tcl-8.3.3"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i -e "s/relid'/relid/" \
configure tcl.m4 tclconfig/tcl.m4 expat/configure || die
}
src_compile() {
- econf || die
+ econf
make || die
# Need to hack the config script.
- sed -i 's:NONE:/usr:' TclxmlConfig.sh
+ sed -i 's:NONE:/usr:' TclxmlConfig.sh || die
}
src_install() {
einstall || die
- dodoc ChangeLog LICENSE README RELNOTES
+ dodoc ChangeLog README RELNOTES || die
}