summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-12 01:35:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-12 01:35:36 +0000
commit933b55ba33f0a7a22f87c9ff5726963d5c6f5c54 (patch)
tree27431e86d9cbffe410d805a749a3bc3397a90f12 /dev-util/astyle
parentBump (diff)
downloadgentoo-2-933b55ba33f0a7a22f87c9ff5726963d5c6f5c54.tar.gz
gentoo-2-933b55ba33f0a7a22f87c9ff5726963d5c6f5c54.tar.bz2
gentoo-2-933b55ba33f0a7a22f87c9ff5726963d5c6f5c54.zip
Bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/astyle')
-rw-r--r--dev-util/astyle/ChangeLog11
-rw-r--r--dev-util/astyle/astyle-1.23.ebuild72
2 files changed, 80 insertions, 3 deletions
diff --git a/dev-util/astyle/ChangeLog b/dev-util/astyle/ChangeLog
index 537316936e6f..f154ba8d609d 100644
--- a/dev-util/astyle/ChangeLog
+++ b/dev-util/astyle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/astyle
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.36 2009/02/18 03:03:32 nerdboy Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.37 2009/09/12 01:35:36 patrick Exp $
+
+*astyle-1.23 (12 Sep 2009)
+
+ 12 Sep 2009; Patrick Lauer <patrick@gentoo.org> +astyle-1.23.ebuild:
+ Bump
18 Feb 2009; Steve Arnold <nerdboy@gentoo.org> astyle-1.22.ebuild:
updated DEPs to use jdk instead of jre (fixes bug #256610)
@@ -69,7 +74,7 @@
Dropped ppc-macos keyword, see you in prefix
14 Nov 2007; Robin H. Johnson <robbat2@gentoo.org> astyle-1.21.ebuild:
- Fix $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.36 2009/02/18 03:03:32 nerdboy Exp $ string.
+ Fix $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/ChangeLog,v 1.37 2009/09/12 01:35:36 patrick Exp $ string.
*astyle-1.21 (07 Oct 2007)
diff --git a/dev-util/astyle/astyle-1.23.ebuild b/dev-util/astyle/astyle-1.23.ebuild
new file mode 100644
index 000000000000..7d22167bb6e4
--- /dev/null
+++ b/dev-util/astyle/astyle-1.23.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/astyle/astyle-1.23.ebuild,v 1.1 2009/09/12 01:35:36 patrick Exp $
+
+EAPI="2"
+
+inherit eutils java-pkg-opt-2 toolchain-funcs
+
+DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug java libs"
+
+RDEPEND="java? ( >=virtual/jdk-1.6 )"
+
+DEPEND="java? ( >=virtual/jdk-1.6 )"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # Add basic soname to make QA happy...
+ sed -i -e "s:-shared:-shared -Wl,-soname,\$@ :g" buildgcc/Makefile
+ # Fix JAVA_HOME
+ sed -i -e \
+ "s:/usr/lib/jvm/java-6-sun-1.6.0.00:$(java-config --jdk-home):g" \
+ buildgcc/Makefile || die "sed failed"
+ # respect CFLAGS, remove strip and other hard-coded crap
+ epatch "${FILESDIR}"/${PN}-1.22-Makefile.patch
+}
+
+src_compile() {
+ cd buildgcc
+
+ emake CXX="$(tc-getCXX)" all $(use java && echo javaall) \
+ || die "build failed"
+}
+
+src_install() {
+ if use debug ; then
+ newbin bin/astyled astyle || die "install debug bin failed"
+ newlib.a bin/libastyled.a libastyle.a \
+ || die "install debug static lib failed"
+ if use libs ; then
+ newlib.so bin/libastyled.so libastyle.so \
+ || die "install debug shared lib failed"
+ if use java ; then
+ local j_dir="/usr/$(get_libdir)"
+ dolib.so bin/libastylejd.so \
+ || die "install debug shared java lib failed"
+ java-pkg_regso "${D}${j_dir}/libastylejd.so"
+ fi
+ fi
+ else
+ if use libs ; then
+ dolib.so bin/libastyle.so || die "install shared lib failed"
+ if use java ; then
+ local j_dir="/usr/$(get_libdir)"
+ dolib.so bin/libastylej.so \
+ || die "install shared java lib failed"
+ java-pkg_regso "${D}${j_dir}/libastylej.so"
+ fi
+ fi
+ dobin bin/astyle || die "install bin failed"
+ dolib.a bin/libastyle.a || die "install static lib failed"
+ fi
+ dohtml doc/*.html
+}