summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-12-13 21:18:38 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-12-13 21:18:38 +0000
commit7148ad9803f4c85b6ee8cdf0ff0af6d68fb08533 (patch)
tree15c4a17090eafcfc852ef1a4dbe4e2a631c38244 /dev-util/cmake/cmake-2.0.6-r1.ebuild
parentInitial import. Original ebuild by Paul Bredbury <brebs@sent.com> and ported... (diff)
downloadgentoo-2-7148ad9803f4c85b6ee8cdf0ff0af6d68fb08533.tar.gz
gentoo-2-7148ad9803f4c85b6ee8cdf0ff0af6d68fb08533.tar.bz2
gentoo-2-7148ad9803f4c85b6ee8cdf0ff0af6d68fb08533.zip
restore 2.0.6-r1 for mips stable
(Portage version: 2.1.2_rc3-r4)
Diffstat (limited to 'dev-util/cmake/cmake-2.0.6-r1.ebuild')
-rw-r--r--dev-util/cmake/cmake-2.0.6-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/cmake/cmake-2.0.6-r1.ebuild b/dev-util/cmake/cmake-2.0.6-r1.ebuild
new file mode 100644
index 000000000000..400425700a7f
--- /dev/null
+++ b/dev-util/cmake/cmake-2.0.6-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.0.6-r1.ebuild,v 1.7 2006/12/13 21:18:38 genstef Exp $
+
+inherit debug flag-o-matic toolchain-funcs eutils
+
+SHORT_PV=2.0
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v${SHORT_PV}/${P}.tar.gz"
+
+LICENSE="CMake"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ia64 mips ppc sparc x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-rpath-fix.patch
+}
+
+src_compile() {
+ strip-flags
+ ./bootstrap \
+ --prefix=/usr \
+ --docdir=/share/doc/${PN} \
+ --datadir=/share/${PN} \
+ --mandir=/share/man || die "./bootstrap failed"
+ emake || die
+}
+
+src_test() {
+ einfo "Self tests broken"
+ #make test || einfo "note test failure on #17 was expected"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "install failed"
+ mv ${D}usr/share/doc/cmake ${D}usr/share/doc/${PF}
+}