summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2014-01-10 19:25:41 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2014-01-10 19:25:41 +0000
commit6187de04d768c5865603c4139fe784fad217d2a4 (patch)
treec110d3f183161f4a43afde7d2eba580d8aa8b093 /dev-util/mingw64-runtime
parentversion bump, cleanup (diff)
downloadgentoo-2-6187de04d768c5865603c4139fe784fad217d2a4.tar.gz
gentoo-2-6187de04d768c5865603c4139fe784fad217d2a4.tar.bz2
gentoo-2-6187de04d768c5865603c4139fe784fad217d2a4.zip
Version bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'dev-util/mingw64-runtime')
-rw-r--r--dev-util/mingw64-runtime/ChangeLog9
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-3.1.0.ebuild79
2 files changed, 86 insertions, 2 deletions
diff --git a/dev-util/mingw64-runtime/ChangeLog b/dev-util/mingw64-runtime/ChangeLog
index a2b8a234ad9c..3bedef42b716 100644
--- a/dev-util/mingw64-runtime/ChangeLog
+++ b/dev-util/mingw64-runtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/mingw64-runtime
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/ChangeLog,v 1.14 2013/10/13 19:23:48 alonbl Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/ChangeLog,v 1.15 2014/01/10 19:25:41 alonbl Exp $
+
+*mingw64-runtime-3.1.0 (10 Jan 2014)
+
+ 10 Jan 2014; Alon Bar-Lev <alonbl@gentoo.org> +mingw64-runtime-3.1.0.ebuild:
+ Version bump
13 Oct 2013; Alon Bar-Lev <alonbl@gentoo.org> metadata.xml,
mingw64-runtime-3.0.0.ebuild:
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-3.1.0.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-3.1.0.ebuild
new file mode 100644
index 000000000000..49e7bbf091b0
--- /dev/null
+++ b/dev-util/mingw64-runtime/mingw64-runtime-3.1.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/mingw64-runtime-3.1.0.ebuild,v 1.1 2014/01/10 19:25:41 alonbl Exp $
+
+EAPI=5
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Free Win64 runtime and import library definitions"
+HOMEPAGE="http://mingw-w64.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crosscompile_opts_headers-only idl"
+RESTRICT="strip"
+
+S="${WORKDIR}/mingw-w64-v${PV}"
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+just_headers() {
+ use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration"
+ fi
+}
+
+src_configure() {
+ local extra_conf=()
+
+ if just_headers; then
+ extra_conf+=( --without-crt )
+ else
+ extra_conf+=( --with-crt )
+ fi
+
+ case ${CTARGET} in
+ x86_64*) extra_conf+=( --disable-lib32 --enable-lib64 ) ;;
+ i?86*) extra_conf+=( --enable-lib32 --disable-lib64 ) ;;
+ *) die "Unsupported ${CTARGET}" ;;
+ esac
+
+ CHOST=${CTARGET} strip-unsupported-flags
+ CHOST=${CTARGET} econf \
+ --prefix=/usr/${CTARGET} \
+ --includedir=/usr/${CTARGET}/usr/include \
+ --with-headers \
+ --enable-sdk \
+ $(use_enable idl) \
+ "${extra_conf[@]}"
+}
+
+src_install() {
+ default
+
+ if is_crosscompile ; then
+ # gcc is configured to look at specific hard-coded paths for mingw #419601
+ dosym usr /usr/${CTARGET}/mingw
+ dosym usr /usr/${CTARGET}/${CTARGET}
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ rm -rf "${ED}/usr/share"
+}