summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-10-27 11:54:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-10-27 11:54:51 +0000
commit05107421f248220d6d5c523c87896963d9b0ceb0 (patch)
tree9f81ada0464a623ad7bd02f900a8c1a44ec6dd35 /dev-util/omake
parentversion bump, by Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>, b... (diff)
downloadgentoo-2-05107421f248220d6d5c523c87896963d9b0ceb0.tar.gz
gentoo-2-05107421f248220d6d5c523c87896963d9b0ceb0.tar.bz2
gentoo-2-05107421f248220d6d5c523c87896963d9b0ceb0.zip
eapi2ify, add build fixes for gcc 4.4 by Barry Schwartz <barryschwartz124@comcast.net>, bug #289819
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/omake')
-rw-r--r--dev-util/omake/ChangeLog10
-rw-r--r--dev-util/omake/files/omake-0.9.8.5-caml_sync.patch11
-rw-r--r--dev-util/omake/files/omake-0.9.8.5-lm_printf.patch32
-rw-r--r--dev-util/omake/omake-0.9.8.5.ebuild24
4 files changed, 62 insertions, 15 deletions
diff --git a/dev-util/omake/ChangeLog b/dev-util/omake/ChangeLog
index 5f8516ff9860..87b719174bd1 100644
--- a/dev-util/omake/ChangeLog
+++ b/dev-util/omake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/omake
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/omake/ChangeLog,v 1.20 2008/04/13 18:21:06 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/omake/ChangeLog,v 1.21 2009/10/27 11:54:51 aballier Exp $
+
+ 27 Oct 2009; Alexis Ballier <aballier@gentoo.org> omake-0.9.8.5.ebuild,
+ +files/omake-0.9.8.5-caml_sync.patch,
+ +files/omake-0.9.8.5-lm_printf.patch:
+ eapi2ify, add build fixes for gcc 4.4 by Barry Schwartz
+ <barryschwartz124@comcast.net>, bug #289819
13 Apr 2008; Alexis Ballier <aballier@gentoo.org> -files/omake-config,
-omake-0.9.6.5.ebuild, -omake-0.9.8.4.ebuild:
diff --git a/dev-util/omake/files/omake-0.9.8.5-caml_sync.patch b/dev-util/omake/files/omake-0.9.8.5-caml_sync.patch
new file mode 100644
index 000000000000..eb8c3a14fe43
--- /dev/null
+++ b/dev-util/omake/files/omake-0.9.8.5-caml_sync.patch
@@ -0,0 +1,11 @@
+--- src/exec/omake_exec.ml.ORIG 2008-12-09 03:49:47.000000000 +0000
++++ src/exec/omake_exec.ml 2008-12-09 03:49:58.000000000 +0000
+@@ -46,8 +46,6 @@
+ open Omake_options
+ open Omake_command_type
+
+-external sync : unit -> unit = "caml_sync"
+-
+ module Exec =
+ struct
+ (*
diff --git a/dev-util/omake/files/omake-0.9.8.5-lm_printf.patch b/dev-util/omake/files/omake-0.9.8.5-lm_printf.patch
new file mode 100644
index 000000000000..3b62f1988937
--- /dev/null
+++ b/dev-util/omake/files/omake-0.9.8.5-lm_printf.patch
@@ -0,0 +1,32 @@
+--- omake-0.9.8.5/src/libmojave-external/cutil/lm_printf.c 2007-07-15 17:55:23.000000000 +0000
++++ 0.9.8.x/src/libmojave-external/cutil/lm_printf.c 2009-10-19 21:24:26.264561909 +0000
+@@ -142,12 +142,12 @@
+ #endif
+ if(code < 0) {
+ if(bufp != buffer)
+- free(buffer);
++ free(bufp);
+ failwith("ml_print_string");
+ }
+ v_result = copy_string(bufp);
+ if(bufp != buffer)
+- free(buffer);
++ free(bufp);
+ return v_result;
+ }
+
+@@ -190,12 +190,12 @@
+ #endif
+ if(code < 0) {
+ if(bufp != buffer)
+- free(buffer);
++ free(bufp);
+ failwith("ml_print_string");
+ }
+ v_result = copy_string(bufp);
+ if(bufp != buffer)
+- free(buffer);
++ free(bufp);
+ return v_result;
+ }
+
diff --git a/dev-util/omake/omake-0.9.8.5.ebuild b/dev-util/omake/omake-0.9.8.5.ebuild
index 286680e1e097..7766a83f87d1 100644
--- a/dev-util/omake/omake-0.9.8.5.ebuild
+++ b/dev-util/omake/omake-0.9.8.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/omake/omake-0.9.8.5.ebuild,v 1.6 2009/10/12 07:55:16 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/omake/omake-0.9.8.5.ebuild,v 1.7 2009/10/27 11:54:51 aballier Exp $
-EAPI=1
+EAPI=2
inherit eutils toolchain-funcs multilib
RESTRICT="installsources"
@@ -15,20 +15,11 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
IUSE="doc fam ncurses +ocamlopt readline"
-DEPEND=">=dev-lang/ocaml-3.0.8
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
ncurses? ( >=sys-libs/ncurses-5.3 )
fam? ( virtual/fam )
readline? ( >=sys-libs/readline-4.3 )"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
use_boolean() {
if use $1; then
echo "true"
@@ -37,7 +28,12 @@ use_boolean() {
fi
}
-src_compile() {
+src_prepare() {
+ epatch "${FILESDIR}/${P}-caml_sync.patch"
+ epatch "${FILESDIR}/${P}-lm_printf.patch"
+}
+
+src_configure() {
# Configuration steps...
echo "PREFIX = \$(dir \$\"/usr\")" > .config
echo "BINDIR = \$(dir \$\"\$(PREFIX)/bin\")" >> .config
@@ -64,7 +60,9 @@ src_compile() {
echo "DEFAULT_SAVE_INTERVAL = 60" >> .config
echo "OCAMLDEP_MODULES_ENABLED = false" >> .config
+}
+src_compile() {
emake all || die "compilation failed"
}