summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2012-01-23 13:58:14 +0000
committerJeremy Olexa <darkside@gentoo.org>2012-01-23 13:58:14 +0000
commit5249b84d2bfb690e4886630a44c879fdbab7b446 (patch)
tree798994a429366b3a0af8b8c89fced8d6c4cc3374 /dev-vcs
parentBump agda to 2.3.0 bug #349460 (diff)
downloadgentoo-2-5249b84d2bfb690e4886630a44c879fdbab7b446.tar.gz
gentoo-2-5249b84d2bfb690e4886630a44c879fdbab7b446.tar.bz2
gentoo-2-5249b84d2bfb690e4886630a44c879fdbab7b446.zip
Version bump, bug 399631 by René 'Necoro' Neumann
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/stgit/ChangeLog9
-rw-r--r--dev-vcs/stgit/stgit-0.16.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/dev-vcs/stgit/ChangeLog b/dev-vcs/stgit/ChangeLog
index 687aecf49ac0..6df05ffc3a12 100644
--- a/dev-vcs/stgit/ChangeLog
+++ b/dev-vcs/stgit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/stgit
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/stgit/ChangeLog,v 1.11 2011/12/30 15:43:10 halcy0n Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/stgit/ChangeLog,v 1.12 2012/01/23 13:58:14 darkside Exp $
+
+*stgit-0.16 (23 Jan 2012)
+
+ 23 Jan 2012; Jeremy Olexa <darkside@gentoo.org> +stgit-0.16.ebuild:
+ Version bump, bug 399631 by René 'Necoro' Neumann
30 Dec 2011; Mark Loeser <halcy0n@gentoo.org> stgit-0.14.3.ebuild:
Revert to ~ppc/~ppc64; bug #381127
diff --git a/dev-vcs/stgit/stgit-0.16.ebuild b/dev-vcs/stgit/stgit-0.16.ebuild
new file mode 100644
index 000000000000..cd1748729e26
--- /dev/null
+++ b/dev-vcs/stgit/stgit-0.16.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/stgit/stgit-0.16.ebuild,v 1.1 2012/01/23 13:58:14 darkside Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils bash-completion-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz
+ mirror://gentoo/${PN}-0.15-missing-patches.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future. Reference should be the online
+# man pages. (As of this writing, they use 8.2.7).
+DEPEND="$RDEPEND
+ doc? (
+ =app-text/asciidoc-8.2*
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+pkg_setup () {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_compile() {
+ # git throws errors if it cannot write its config file
+ # thus feed it a dummy one
+ touch gitconfig
+ export GIT_CONFIG="${S}/gitconfig"
+
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+
+ # do not call normal 'emake' s.t. Gentoo's Python handling
+ # can do its work
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ # do not use 'emake install-*' as the pathes are wrong
+ # and fixing them is more work than just using the following
+ doman Documentation/*.1 || die "doman failed"
+ dohtml Documentation/*.html || die "dohtml failed"
+ fi
+
+ newbashcomp stgit-completion.bash ${PN} || die
+}