summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-12-23 00:32:02 +0000
committerJonathan Callen <abcd@gentoo.org>2009-12-23 00:32:02 +0000
commitc4d6ca62e5b5560f6f507847cfb0d40a22702bd2 (patch)
treec774142507c7a93f89f7898760936bcbc1bb9233 /eclass/cmake-utils.eclass
parentPull in changes from overlay and patch for prefix support (Solaris) (diff)
downloadgentoo-2-c4d6ca62e5b5560f6f507847cfb0d40a22702bd2.tar.gz
gentoo-2-c4d6ca62e5b5560f6f507847cfb0d40a22702bd2.tar.bz2
gentoo-2-c4d6ca62e5b5560f6f507847cfb0d40a22702bd2.zip
Fixes from kde overlay
Diffstat (limited to 'eclass/cmake-utils.eclass')
-rw-r--r--eclass/cmake-utils.eclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index cd83fcfef690..c3d85fa1bcfb 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/cmake-utils.eclass,v 1.39 2009/12/22 22:52:52 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/cmake-utils.eclass,v 1.40 2009/12/23 00:32:02 abcd Exp $
# @ECLASS: cmake-utils.eclass
# @MAINTAINER:
@@ -231,7 +231,7 @@ cmake-utils_use_has() { _use_me_now HAVE_ "$@" ; }
cmake-utils_use() { _use_me_now "" "$@" ; }
# Internal function for modifying hardcoded definitions.
-# Removes dangerous definitionts that override Gentoo settings.
+# Removes dangerous definitions that override Gentoo settings.
_modify-cmakelists() {
debug-print-function ${FUNCNAME} "$@"
@@ -246,8 +246,8 @@ _modify-cmakelists() {
cat >> CMakeLists.txt <<- _EOF_
MESSAGE(STATUS "<<< Gentoo configuration >>>
- Build type: ${CMAKE_BUILD_TYPE}
- Install path: ${CMAKE_INSTALL_PREFIX}\n")
+ Build type: \${CMAKE_BUILD_TYPE}
+ Install path: \${CMAKE_INSTALL_PREFIX}\n")
_EOF_
}