summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-05-12 04:21:55 +0000
committerMike Frysinger <vapier@gentoo.org>2010-05-12 04:21:55 +0000
commit85fe711b1fa484b97e34b0629c90a7514da87f74 (patch)
treebeea474205d51f873cdd28ced4537d031164c89e /games-action/lugaru
parentVersion bump to 20a. (diff)
downloadgentoo-2-85fe711b1fa484b97e34b0629c90a7514da87f74.tar.gz
gentoo-2-85fe711b1fa484b97e34b0629c90a7514da87f74.tar.bz2
gentoo-2-85fe711b1fa484b97e34b0629c90a7514da87f74.zip
Initial ebuild based on current lugaru-demo ebuild.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'games-action/lugaru')
-rw-r--r--games-action/lugaru/ChangeLog10
-rw-r--r--games-action/lugaru/lugaru-1.0c.ebuild54
-rw-r--r--games-action/lugaru/metadata.xml5
3 files changed, 69 insertions, 0 deletions
diff --git a/games-action/lugaru/ChangeLog b/games-action/lugaru/ChangeLog
new file mode 100644
index 000000000000..63050d946210
--- /dev/null
+++ b/games-action/lugaru/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/lugaru
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/lugaru/ChangeLog,v 1.1 2010/05/12 04:21:55 vapier Exp $
+
+*lugaru-1.0c (12 May 2010)
+
+ 12 May 2010; Mike Frysinger <vapier@gentoo.org> +lugaru-1.0c.ebuild,
+ +metadata.xml:
+ Initial ebuild based on current lugaru-demo ebuild.
+
diff --git a/games-action/lugaru/lugaru-1.0c.ebuild b/games-action/lugaru/lugaru-1.0c.ebuild
new file mode 100644
index 000000000000..941f76274fcc
--- /dev/null
+++ b/games-action/lugaru/lugaru-1.0c.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/lugaru/lugaru-1.0c.ebuild,v 1.1 2010/05/12 04:21:55 vapier Exp $
+
+inherit eutils games
+
+DESCRIPTION="3D arcade with unique fighting system and antropomorphic characters"
+HOMEPAGE="http://www.wolfire.com/lugaru"
+SRC_URI="${PN}-full-linux-x86-${PV}.bin"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/glibc
+ amd64? ( app-emulation/emul-linux-x86-xlibs )
+ x86? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )"
+
+S=${WORKDIR}/data
+
+src_unpack() {
+ # self unpacking zip archive; unzip warns about the exe stuff
+ local a="${DISTDIR}/${A}"
+ echo ">>> Unpacking ${a} to ${PWD}"
+ unzip -q "${a}"
+ [ $? -gt 1 ] && die "unpacking failed"
+
+ # Duplicate file and can't be handled by portage, bug #14983
+ rm -f "${S}/Data/Textures/Quit.png "
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/lugaru
+
+ insinto "${dir}"
+ doins -r Data || die "doins failed"
+
+ dodoc *.txt
+
+ exeinto "${dir}"
+ doexe ${PN} || die "doexe failed"
+ games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+
+ doicon ${PN}.png
+ make_desktop_entry ${PN} Lugaru ${PN}
+
+ prepgamesdirs
+}
diff --git a/games-action/lugaru/metadata.xml b/games-action/lugaru/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/lugaru/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>