summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-13 21:08:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-13 21:08:27 +0000
commit84dbd300a877f7c70b323d2658b3282fa326c955 (patch)
tree316573cbbdbe699287cb9671ef60fc848bf6324e /games-arcade/epiar
parent"Disable" NLS support; CVS is not using NLS support, and by leaving it to aut... (diff)
downloadgentoo-2-84dbd300a877f7c70b323d2658b3282fa326c955.tar.gz
gentoo-2-84dbd300a877f7c70b323d2658b3282fa326c955.tar.bz2
gentoo-2-84dbd300a877f7c70b323d2658b3282fa326c955.zip
tidy
(Portage version: 2.0.53)
Diffstat (limited to 'games-arcade/epiar')
-rw-r--r--games-arcade/epiar/epiar-0.5.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/games-arcade/epiar/epiar-0.5.ebuild b/games-arcade/epiar/epiar-0.5.ebuild
index c0de05eb83df..12bf59fc250d 100644
--- a/games-arcade/epiar/epiar-0.5.ebuild
+++ b/games-arcade/epiar/epiar-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/epiar/epiar-0.5.ebuild,v 1.7 2004/07/01 03:08:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/epiar/epiar-0.5.ebuild,v 1.8 2006/01/13 21:08:27 mr_bones_ Exp $
inherit flag-o-matic eutils games
@@ -10,29 +10,29 @@ SRC_URI="mirror://sourceforge/epiar/${P}.0-src.zip"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~ppc ~x86"
IUSE=""
RDEPEND="virtual/x11
- virtual/libc
media-libs/libsdl
media-libs/sdl-image"
DEPEND="${RDEPEND}
- >=sys-apps/sed-4
app-arch/unzip"
-S="${WORKDIR}"
+S=${WORKDIR}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
- -e "/^CFLAGS/s:-pg -g:${CFLAGS}:" Makefile.linux \
- || die "sed Makefile.linux failed"
- epatch ${FILESDIR}/${PV}-gentoo-paths.patch
+ -e "/^CFLAGS/s:-pg -g:${CFLAGS}:" \
+ Makefile.linux \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${PV}-gentoo-paths.patch
sed -i \
- -e "s:GENTOO_DATAPATH:${GAMES_DATADIR}/${PN}/:" src/system/path.c \
- || die "sed src/system/path.c failed"
+ -e "s:GENTOO_DATAPATH:${GAMES_DATADIR}/${PN}/:" \
+ src/system/path.c \
+ || die "sed failed"
}
src_compile() {
@@ -44,8 +44,8 @@ src_install() {
insinto "${GAMES_DATADIR}/${PN}"
doins *.eaf || die "doins failed"
insinto "${GAMES_DATADIR}/${PN}/missions"
- doins missions/*.eaf || die "doins failed (missions)"
- dodir "${GAMES_DATADIR}/${PN}/plugins"
+ doins missions/*.eaf || die "doins failed"
+ keepdir "${GAMES_DATADIR}/${PN}/plugins"
dodoc AUTHORS ChangeLog README
prepgamesdirs
}