summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-03-16 08:57:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-03-16 08:57:32 +0000
commit425acdeae74b7e8012d8604e3dd3119ef77639c3 (patch)
treebab62cb323aff03a27362fff632b185742aeb48e /games-board/crafty
parentUpdate PyPy flag descriptions. (diff)
downloadgentoo-2-425acdeae74b7e8012d8604e3dd3119ef77639c3.tar.gz
gentoo-2-425acdeae74b7e8012d8604e3dd3119ef77639c3.tar.bz2
gentoo-2-425acdeae74b7e8012d8604e3dd3119ef77639c3.zip
version bump (bug #501884)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board/crafty')
-rw-r--r--games-board/crafty/ChangeLog9
-rw-r--r--games-board/crafty/crafty-23.8.ebuild84
2 files changed, 91 insertions, 2 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index 1acb4fff91fa..c199f9966525 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/crafty
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.55 2013/04/07 21:21:53 tupone Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.56 2014/03/16 08:57:32 mr_bones_ Exp $
+
+*crafty-23.8 (16 Mar 2014)
+
+ 16 Mar 2014; Michael Sterrett <mr_bones_@gentoo.org> +crafty-23.8.ebuild:
+ version bump (bug #501884)
07 Apr 2013; Alfredo Tupone <tupone@gentoo.org> crafty-23.4.ebuild,
+files/crafty-23.4-64bits.patch:
diff --git a/games-board/crafty/crafty-23.8.ebuild b/games-board/crafty/crafty-23.8.ebuild
new file mode 100644
index 000000000000..4db7a05377dd
--- /dev/null
+++ b/games-board/crafty/crafty-23.8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-23.8.ebuild,v 1.1 2014/03/16 08:57:32 mr_bones_ Exp $
+
+EAPI=5
+inherit flag-o-matic toolchain-funcs eutils games
+
+DESCRIPTION="Bob Hyatt's strong chess engine"
+HOMEPAGE="http://www.craftychess.com/"
+SRC_URI="http://www.craftychess.com/${P}.zip
+ http://www.cis.uab.edu/hyatt/crafty/source/${P}.zip
+ ftp://ftp.cis.uab.edu/pub/hyatt/documentation/${PN}.doc.ascii"
+
+LICENSE="crafty"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="no-opts"
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ sed -i \
+ -e '/-o crafty/s/CC/CXX/' \
+ -e 's:CXFLAGS:CXXFLAGS:g' \
+ Makefile || die
+ sed -i \
+ -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c || die
+}
+
+src_compile() {
+ local makeopts="target=LINUX"
+
+ if ! use no-opts ; then
+ if [[ $(tc-getCC) = icc ]] ; then
+ makeopts="${makeopts} asm=X86.o"
+ append-flags -D_REENTRANT -tpp6 \
+ -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
+ -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -O2 -fno-alias -fforce-mem \
+ -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
+ else
+ if [[ "${CHOST}" == "i686-pc-linux-gnu" ]] \
+ || [[ "${CHOST}" == "i586-pc-linux-gnu" ]] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fno-gcse \
+ -fomit-frame-pointer -mpreferred-stack-boundary=2
+ elif [[ "${CHOST}" == "x86_64-pc-linux-gnu" ]] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fomit-frame-pointer
+ else
+ : # everything else :)
+ fi
+ fi
+ fi
+ append-flags -DPOSIX -DSKILL
+ emake ${makeopts} crafty-make LDFLAGS="${LDFLAGS} -pthread"
+}
+
+src_install() {
+ dogamesbin crafty
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins crafty.hlp
+ dodoc "${DISTDIR}"/crafty.doc.ascii
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog
+ elog "Note: No books or tablebases have been installed. If you want them, just"
+ elog " download them from ${HOMEPAGE}."
+ elog " You will find documentation there too. In most cases you take now "
+ elog " your xboard compatible application, (xboard, eboard, knights) and "
+ elog " just play chess against computer opponent. Have fun."
+ elog
+}