summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-12-30 21:16:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-12-30 21:16:47 +0000
commite907f17b3e81e6a39c507fedfd281be112a7a11a (patch)
tree39ea3ad7ba1a61574211e886ea1928d313bc6a4e /games-board/gnushogi
parentversion bump (diff)
downloadgentoo-2-e907f17b3e81e6a39c507fedfd281be112a7a11a.tar.gz
gentoo-2-e907f17b3e81e6a39c507fedfd281be112a7a11a.tar.bz2
gentoo-2-e907f17b3e81e6a39c507fedfd281be112a7a11a.zip
EAPI=2
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-board/gnushogi')
-rw-r--r--games-board/gnushogi/gnushogi-1.3.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/games-board/gnushogi/gnushogi-1.3.ebuild b/games-board/gnushogi/gnushogi-1.3.ebuild
index 29396c37f1cc..4a2e8fbe9582 100644
--- a/games-board/gnushogi/gnushogi-1.3.ebuild
+++ b/games-board/gnushogi/gnushogi-1.3.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/gnushogi-1.3.ebuild,v 1.15 2009/12/22 22:15:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/gnushogi-1.3.ebuild,v 1.16 2009/12/30 21:16:47 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="Japanese version of chess (commandline + X-Version)"
@@ -19,11 +20,9 @@ DEPEND="${RDEPEND}
>=sys-devel/bison-1.34
>=sys-devel/flex-2.5"
-src_unpack() {
+src_prepare() {
local f
- unpack ${A}
- cd "${S}"
for f in $(grep -Rl -- -ltermcap *) ; do
einfo "Fixing ${f}"
sed -i \
@@ -34,12 +33,14 @@ src_unpack() {
"${FILESDIR}/${P}"-gcc4.patch
}
-src_compile() {
+src_configure() {
egamesconf \
$(use_with X x) \
$(use_with X xshogi) || die
addpredict /usr/games/lib/gnushogi/gnushogi.hsh
+}
+src_compile() {
# bug #298017
emake -j1 || die "emake failed"
}