summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-23 01:32:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-23 01:32:53 +0000
commit089a4826767b54e57f39aaa65cec5fa92ad592f8 (patch)
treef37c70e9a8aab13740796726fd54a29cc6014b23 /games-board
parentpass through -j to scons (diff)
downloadgentoo-2-089a4826767b54e57f39aaa65cec5fa92ad592f8.tar.gz
gentoo-2-089a4826767b54e57f39aaa65cec5fa92ad592f8.tar.bz2
gentoo-2-089a4826767b54e57f39aaa65cec5fa92ad592f8.zip
just pass -j to scons from MAKEOPTS
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pouetchess/pouetchess-0.2.0-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
index 09c1f75d1a79..783514173b62 100644
--- a/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
+++ b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild,v 1.8 2009/07/23 15:45:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild,v 1.9 2009/11/23 01:32:53 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -49,7 +49,7 @@ src_configure() {
}
src_compile() {
- local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[0-9]\+\).*/\1/; p }")
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
scons ${sconsopts} || die "scons failed"
}