summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-02 22:47:28 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-02 22:47:28 +0000
commitf053bdbb0dfbdfcaf6afe910729a15adc2f2f807 (patch)
tree60b62eb64520cba12bf14cad6a0b8b24a0ae21be /games-board
parentRedigest for weird CVS failure. (diff)
downloadgentoo-2-f053bdbb0dfbdfcaf6afe910729a15adc2f2f807.tar.gz
gentoo-2-f053bdbb0dfbdfcaf6afe910729a15adc2f2f807.tar.bz2
gentoo-2-f053bdbb0dfbdfcaf6afe910729a15adc2f2f807.zip
Version bump
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/crafty/ChangeLog7
-rw-r--r--games-board/crafty/crafty-20.14.ebuild78
-rw-r--r--games-board/crafty/files/digest-crafty-20.143
3 files changed, 87 insertions, 1 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index d0340993f100..90236c4fab4b 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/crafty
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.18 2006/06/08 22:35:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.19 2006/10/02 22:47:28 nyhm Exp $
+
+*crafty-20.14 (02 Oct 2006)
+
+ 02 Oct 2006; Tristan Heaven <nyhm@gentoo.org> +crafty-20.14.ebuild:
+ Version bump
*crafty-20.13 (08 Jun 2006)
diff --git a/games-board/crafty/crafty-20.14.ebuild b/games-board/crafty/crafty-20.14.ebuild
new file mode 100644
index 000000000000..28e4c385f92e
--- /dev/null
+++ b/games-board/crafty/crafty-20.14.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-20.14.ebuild,v 1.1 2006/10/02 22:47:28 nyhm Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="Bob Hyatt's strong chess engine"
+HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
+SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip"
+
+LICENSE="crafty"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="icc no-opts"
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ icc? ( >=dev-lang/icc-5.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/-o crafty/s/CC/CXX/' Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ local makeopts="target=LINUX"
+
+ if ! use no-opts ; then
+ if use icc ; then
+ makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
+ append-flags -D_REENTRANT -tpp6 \
+ -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
+ -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -O2 -fno-alias -fforce-mem \
+ -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
+ else
+ if [ "${CHOST}" == "i686-pc-linux-gnu" ] || [ "${CHOST}" == "i586-pc-linux-gnu" ] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fforce-mem -fno-gcse \
+ -fomit-frame-pointer -mpreferred-stack-boundary=2
+ makeopts="${makeopts} CC=gcc CXX=g++ asm=X86.o"
+ else
+ : # everything else :)
+ fi
+ fi
+ fi
+ append-flags -DPOSIX
+ emake ${makeopts} crafty-make LDFLAGS="${LDFLAGS} -lpthread" || die "build failed"
+}
+
+src_install() {
+ dogamesbin crafty || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins crafty.hlp || die "doins failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo
+ einfo "Note: No books or tablebases have been installed. If you want them, just"
+ einfo " download them from ${HOMEPAGE}."
+ einfo " You will find documentation there too. In most cases you take now "
+ einfo " your xboard compatible application, (xboard, eboard, knights) and "
+ einfo " just play chess against computer opponent. Have fun."
+ einfo
+}
diff --git a/games-board/crafty/files/digest-crafty-20.14 b/games-board/crafty/files/digest-crafty-20.14
new file mode 100644
index 000000000000..cbdf4f1fc0cb
--- /dev/null
+++ b/games-board/crafty/files/digest-crafty-20.14
@@ -0,0 +1,3 @@
+MD5 ab681d84fc2f01ce0789cf4f47c945f8 crafty-20.14.zip 422894
+RMD160 a68e46b1d68ffa77c477d707e4003737c786e11f crafty-20.14.zip 422894
+SHA256 9e4b90bde9c156ad537d6228c678d39dcaf790a0603125ab37ed48fb4662a01a crafty-20.14.zip 422894