summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-20 06:48:15 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-20 06:48:15 +0000
commit84a475ca16efd294f86ceb92d19413f382b2cde8 (patch)
treef0025b1cb9eb737d7773a10cfcc59d618a2f9340 /games-rpg/nwn-cep/nwn-cep-1.50.ebuild
parentremove old+broken version (Manifest recommit) (diff)
downloadgentoo-2-84a475ca16efd294f86ceb92d19413f382b2cde8.tar.gz
gentoo-2-84a475ca16efd294f86ceb92d19413f382b2cde8.tar.bz2
gentoo-2-84a475ca16efd294f86ceb92d19413f382b2cde8.zip
initial import #68501
(Portage version: 2.0.51-r13)
Diffstat (limited to 'games-rpg/nwn-cep/nwn-cep-1.50.ebuild')
-rw-r--r--games-rpg/nwn-cep/nwn-cep-1.50.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-rpg/nwn-cep/nwn-cep-1.50.ebuild b/games-rpg/nwn-cep/nwn-cep-1.50.ebuild
new file mode 100644
index 000000000000..a6b68bd122d2
--- /dev/null
+++ b/games-rpg/nwn-cep/nwn-cep-1.50.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn-cep/nwn-cep-1.50.ebuild,v 1.1 2005/01/20 06:48:15 vapier Exp $
+
+inherit games
+
+DESCRIPTION="The Community Expansion Pack is a high quality custom content addon"
+HOMEPAGE="http://nwn.bioware.com/players/cep.html"
+SRC_URI="cepv${PV//.}man.rar"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="fetch"
+
+DEPEND="app-arch/unrar"
+RDEPEND=">=games-rpg/nwn-1.65"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please visit http://nwvault.ign.com/cep/downloads/"
+ einfo "and download the .rar version."
+ einfo "Then move the file you download to:"
+ einfo "${DISTDIR}/${A}"
+}
+
+src_unpack() {
+ unrar x "${DISTDIR}"/${A} || die "unpacking ${A}"
+}
+
+src_install() {
+ dodir "${GAMES_PREFIX_OPT}"/nwn/{hak,tlk,modules,cep}
+ mv *.hak "${D}/${GAMES_PREFIX_OPT}"/nwn/hak/ || die "hak failed"
+ local hak cep
+ if has_version games-rpg/nwn-hotu ; then
+ hak=HotU
+ cep="Live SoU"
+ elif has_version games-rpg/nwn-sou ; then
+ hak=SoU
+ cep="Live HotU"
+ else
+ hak=Live
+ cep="HotU SoU"
+ fi
+ mv ${hak}/* "${D}/${GAMES_PREFIX_OPT}"/nwn/hak/ || die "hak2 failed"
+ mv ${cep} "${D}/${GAMES_PREFIX_OPT}"/nwn/cep/ || die "cep failed"
+ mv cep.tlk "${D}/${GAMES_PREFIX_OPT}"/nwn/tlk/ || die "tlk failed"
+ mv *.mod "${D}/${GAMES_PREFIX_OPT}"/nwn/modules/ || die "mod failed"
+ mv *.pdf *.txt "${D}/${GAMES_PREFIX_OPT}"/nwn/cep/ || die "docs failed"
+ prepgamesdirs
+}