summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-08-29 17:58:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-08-29 17:58:08 +0000
commit816cd160089153abc2cd91d41bb9ab4881b7ca01 (patch)
treecf91afc51661431f5a3c42815537393f283ced6d /games-strategy/coldwar
parenttidy (diff)
downloadgentoo-2-816cd160089153abc2cd91d41bb9ab4881b7ca01.tar.gz
gentoo-2-816cd160089153abc2cd91d41bb9ab4881b7ca01.tar.bz2
gentoo-2-816cd160089153abc2cd91d41bb9ab4881b7ca01.zip
tidy; clean old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy/coldwar')
-rw-r--r--games-strategy/coldwar/ChangeLog6
-rw-r--r--games-strategy/coldwar/coldwar-1.0.1-r1.ebuild14
-rw-r--r--games-strategy/coldwar/coldwar-1.0.1.ebuild77
3 files changed, 12 insertions, 85 deletions
diff --git a/games-strategy/coldwar/ChangeLog b/games-strategy/coldwar/ChangeLog
index c72de276460b..59ebea20d0d5 100644
--- a/games-strategy/coldwar/ChangeLog
+++ b/games-strategy/coldwar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/coldwar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar/ChangeLog,v 1.7 2014/06/25 17:28:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar/ChangeLog,v 1.8 2014/08/29 17:58:08 mr_bones_ Exp $
+
+ 29 Aug 2014; Michael Sterrett <mr_bones_@gentoo.org> -coldwar-1.0.1.ebuild,
+ coldwar-1.0.1-r1.ebuild:
+ tidy; clean old
25 Jun 2014; Michał Górny <mgorny@gentoo.org> coldwar-1.0.1-r1.ebuild:
Update multilib dependencies to use the lowest known EAPI 5 or multilib
diff --git a/games-strategy/coldwar/coldwar-1.0.1-r1.ebuild b/games-strategy/coldwar/coldwar-1.0.1-r1.ebuild
index e99e54be6e1a..7cc769f1b28d 100644
--- a/games-strategy/coldwar/coldwar-1.0.1-r1.ebuild
+++ b/games-strategy/coldwar/coldwar-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar/coldwar-1.0.1-r1.ebuild,v 1.2 2014/06/25 17:28:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar/coldwar-1.0.1-r1.ebuild,v 1.3 2014/08/29 17:58:08 mr_bones_ Exp $
EAPI=5
@@ -54,15 +54,15 @@ src_unpack() {
use linguas_ru && unpack "./cd/langpack_ru.tar.gz"
rm -f cd
- cp -rf "${CDROM_ROOT}"/bin/Linux/x86/* . || die "cp exes failed"
- cp -f "${CDROM_ROOT}"/{READ*,icon*} . || die "cp READ* failed"
+ cp -rf "${CDROM_ROOT}"/bin/Linux/x86/* . || die
+ cp -f "${CDROM_ROOT}"/{READ*,icon*} . || die
- mkdir -p patch
- cd patch
+ mkdir -p patch_dir
+ cd patch_dir
unpack_makeself ${MY_P}-x86.run
- bin/Linux/x86/loki_patch patch.dat "${S}" || die "loki_patch failed"
+ bin/Linux/x86/loki_patch patch.dat "${S}" || die
cd "${S}"
- rm -rf patch
+ rm -rf patch_dir
}
src_install() {
diff --git a/games-strategy/coldwar/coldwar-1.0.1.ebuild b/games-strategy/coldwar/coldwar-1.0.1.ebuild
deleted file mode 100644
index cdf65ef36cb6..000000000000
--- a/games-strategy/coldwar/coldwar-1.0.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar/coldwar-1.0.1.ebuild,v 1.5 2014/04/16 17:11:40 ulm Exp $
-
-inherit eutils unpacker cdrom versionator games
-
-PV_MAJOR=$(get_version_component_range 1-2)
-MY_P=${PN}-${PV_MAJOR}-${PV}
-
-DESCRIPTION="Third-person sneaker like Splinter Cell"
-HOMEPAGE="http://linuxgamepublishing.com/info.php?id=coldwar"
-SRC_URI="http://updatefiles.linuxgamepublishing.com/${PN}/${MY_P}-x86.run"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="linguas_de linguas_fr linguas_ru"
-RESTRICT="mirror bindist strip"
-
-RDEPEND="virtual/opengl
- x86? (
- media-libs/libogg
- media-libs/openal
- media-libs/libvorbis
- media-libs/smpeg
- dev-libs/glib
- x11-libs/libX11
- x11-libs/libXext )
- amd64? (
- app-emulation/emul-linux-x86-sdl
- app-emulation/emul-linux-x86-xlibs
- app-emulation/emul-linux-x86-medialibs )"
-DEPEND=""
-
-S=${WORKDIR}
-
-src_unpack() {
- cdrom_get_cds bin/Linux/x86/${PN}
- ln -sfn "${CDROM_ROOT}"/data cd
- unpack "./cd/data.tar.gz"
- use linguas_de && unpack "./cd/langpack_de.tar.gz"
- use linguas_fr && unpack "./cd/langpack_fr.tar.gz"
- use linguas_ru && unpack "./cd/langpack_ru.tar.gz"
- rm -f cd
-
- cp -rf "${CDROM_ROOT}"/bin/Linux/x86/* . || die "cp exes failed"
- cp -f "${CDROM_ROOT}"/{READ*,icon*} . || die "cp READ* failed"
-
- mkdir -p patch
- cd patch
- unpack_makeself ${MY_P}-x86.run
- bin/Linux/x86/loki_patch patch.dat "${S}" || die "loki_patch failed"
- cd "${S}"
- rm -rf patch
-}
-
-src_install() {
- dir=${GAMES_PREFIX_OPT}/${PN}
-
- insinto "${dir}"
- doins -r * || die "doins -r failed"
-
- exeinto "${dir}"
- doexe ${PN} || die "doexe ${PN} failed"
-
- exeinto "${dir}"/bin
- doexe bin/{launch*,meng} || die "doexe bin failed"
-
- exeinto "${dir}"/lib
- doexe lib/lib* || die "doexe lib/* failed"
-
- games_make_wrapper ${PN} ./${PN} "${dir}"
- newicon "${CDROM_ROOT}"/icon.xpm ${PN}.xpm || die "newicon failed"
- make_desktop_entry ${PN} "Cold War" ${PN}
-
- prepgamesdirs
-}