summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-09-03 15:53:51 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-09-03 15:53:51 +0000
commit9d2aeb811d244f113d7c5c05de4355fe0dfbab71 (patch)
treea5430537b13cb43c39d25844d334e3cb5ad6553c /games-strategy
parentBump to cglib-2.2. (diff)
downloadgentoo-2-9d2aeb811d244f113d7c5c05de4355fe0dfbab71.tar.gz
gentoo-2-9d2aeb811d244f113d7c5c05de4355fe0dfbab71.tar.bz2
gentoo-2-9d2aeb811d244f113d7c5c05de4355fe0dfbab71.zip
Fix building with glibc-2.10
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glest/ChangeLog6
-rw-r--r--games-strategy/glest/files/glest-3.2.2-glibc210.patch10
-rw-r--r--games-strategy/glest/glest-3.2.2.ebuild6
3 files changed, 19 insertions, 3 deletions
diff --git a/games-strategy/glest/ChangeLog b/games-strategy/glest/ChangeLog
index fda01bd00981..0ae84029eb61 100644
--- a/games-strategy/glest/ChangeLog
+++ b/games-strategy/glest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/glest
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.23 2009/07/11 00:36:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.24 2009/09/03 15:53:50 nyhm Exp $
+
+ 03 Sep 2009; Tristan Heaven <nyhm@gentoo.org> glest-3.2.2.ebuild,
+ +files/glest-3.2.2-glibc210.patch:
+ Fix building with glibc-2.10
*glest-3.2.2 (11 Jul 2009)
diff --git a/games-strategy/glest/files/glest-3.2.2-glibc210.patch b/games-strategy/glest/files/glest-3.2.2-glibc210.patch
new file mode 100644
index 000000000000..a68bbf22c3ae
--- /dev/null
+++ b/games-strategy/glest/files/glest-3.2.2-glibc210.patch
@@ -0,0 +1,10 @@
+--- shared_lib/sources/platform/posix/socket.cpp
++++ shared_lib/sources/platform/posix/socket.cpp
+@@ -10,6 +10,7 @@
+
+ #include <cstring>
+ #include <cstdlib>
++#include <cstdio>
+ #include <stdexcept>
+ #include <sstream>
+ #if defined(HAVE_SYS_IOCTL_H)
diff --git a/games-strategy/glest/glest-3.2.2.ebuild b/games-strategy/glest/glest-3.2.2.ebuild
index e9f6680e85c1..8b044db33751 100644
--- a/games-strategy/glest/glest-3.2.2.ebuild
+++ b/games-strategy/glest/glest-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-3.2.2.ebuild,v 1.1 2009/07/11 00:36:39 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-3.2.2.ebuild,v 1.2 2009/09/03 15:53:50 nyhm Exp $
EAPI=2
inherit eutils games
@@ -33,7 +33,9 @@ S=${WORKDIR}/${PN}-source-${PV}
src_prepare() {
epatch \
- "${FILESDIR}"/${P}-{gentoo,xerces-c}.patch
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-xerces-c.patch \
+ "${FILESDIR}"/${P}-glibc210.patch
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \