summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-07-17 00:44:36 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-07-17 00:44:36 +0000
commit2661ac4c6ddf1c618a4c66b9ddfe3411658620e9 (patch)
treef60ce21574d2e3992b7205a12b40f5f1261df493 /games-util
parentAdd live ebuild for testing. (diff)
downloadgentoo-2-2661ac4c6ddf1c618a4c66b9ddfe3411658620e9.tar.gz
gentoo-2-2661ac4c6ddf1c618a4c66b9ddfe3411658620e9.tar.bz2
gentoo-2-2661ac4c6ddf1c618a4c66b9ddfe3411658620e9.zip
fix underlinking wrt #517208
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/higan-purify/ChangeLog8
-rw-r--r--games-util/higan-purify/files/higan-purify-03-QA.patch29
2 files changed, 35 insertions, 2 deletions
diff --git a/games-util/higan-purify/ChangeLog b/games-util/higan-purify/ChangeLog
index 5099fe43c3d1..94fa87613e2e 100644
--- a/games-util/higan-purify/ChangeLog
+++ b/games-util/higan-purify/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/higan-purify
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/higan-purify/ChangeLog,v 1.2 2013/08/13 15:41:46 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/higan-purify/ChangeLog,v 1.3 2014/07/17 00:44:36 hasufell Exp $
+
+ 17 Jul 2014; Julian Ospald <hasufell@gentoo.org>
+ files/higan-purify-03-QA.patch:
+ fix underlinking wrt #517208
13 Aug 2013; Julian Ospald <hasufell@gentoo.org> higan-purify-03.ebuild:
add gcc-4.7 version check wrt #480874
diff --git a/games-util/higan-purify/files/higan-purify-03-QA.patch b/games-util/higan-purify/files/higan-purify-03-QA.patch
index 7594257ac1cc..e523ba4cad95 100644
--- a/games-util/higan-purify/files/higan-purify-03-QA.patch
+++ b/games-util/higan-purify/files/higan-purify-03-QA.patch
@@ -11,3 +11,32 @@
objects := obj/phoenix.o obj/purify.o
ifeq ($(platform),x)
+@@ -22,7 +22,7 @@
+
+ build: $(objects)
+ ifeq ($(platform),x)
+- $(cpp) -pthread $(link) -o purify $(objects) $(phoenixlink)
++ $(cpp) $(flags) -pthread $(link) -o purify $(objects) $(phoenixlink)
+ else ifeq ($(platform),win)
+ windres phoenix/windows/phoenix.rc obj/phoenix-resource.o
+ $(cpp) -shared -o phoenix.dll obj/phoenix.o $(phoenixlink)
+--- purify_v03-source/purify/phoenix/Makefile
++++ purify_v03-source/purify/phoenix/Makefile
+@@ -4,13 +4,13 @@
+ endif
+
+ ifeq ($(phoenix),gtk)
+- phoenixflags := -DPHOENIX_GTK `pkg-config --cflags gtk+-2.0`
+- phoenixlink := `pkg-config --libs gtk+-2.0`
++ phoenixflags := -DPHOENIX_GTK `pkg-config --cflags gtk+-2.0 x11`
++ phoenixlink := `pkg-config --libs gtk+-2.0 x11` -ldl
+ endif
+
+ ifeq ($(phoenix),qt)
+- phoenixflags := -DPHOENIX_QT `pkg-config --cflags QtCore QtGui`
+- phoenixlink := `pkg-config --libs QtCore QtGui`
++ phoenixflags := -DPHOENIX_QT `pkg-config --cflags QtCore QtGui x11`
++ phoenixlink := `pkg-config --libs QtCore QtGui x11` -ldl
+ endif
+ else ifeq ($(platform),win)
+ phoenixflags := -DPHOENIX_WINDOWS