summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-04-14 16:59:19 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-04-14 16:59:19 +0000
commitdae0711ff581dbaeeba92601e5be295cff972013 (patch)
tree42762d71c8fcf3f1b7605b7d036cf2cca1df6633 /games-util
parentcmake is already pulled in by cmake-utils (diff)
downloadgentoo-2-dae0711ff581dbaeeba92601e5be295cff972013.tar.gz
gentoo-2-dae0711ff581dbaeeba92601e5be295cff972013.tar.bz2
gentoo-2-dae0711ff581dbaeeba92601e5be295cff972013.zip
Use system zlib, bug #251109
(Portage version: 2.2_rc30/cvs/Linux i686)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/dzip/ChangeLog10
-rw-r--r--games-util/dzip/dzip-2.9-r2.ebuild42
-rw-r--r--games-util/dzip/files/dzip-2.9-system-zlib.patch52
3 files changed, 102 insertions, 2 deletions
diff --git a/games-util/dzip/ChangeLog b/games-util/dzip/ChangeLog
index e0738f418172..61fa84a58573 100644
--- a/games-util/dzip/ChangeLog
+++ b/games-util/dzip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/dzip
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/dzip/ChangeLog,v 1.9 2008/12/06 15:40:54 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/dzip/ChangeLog,v 1.10 2009/04/14 16:59:19 nyhm Exp $
+
+*dzip-2.9-r2 (14 Apr 2009)
+
+ 14 Apr 2009; Tristan Heaven <nyhm@gentoo.org>
+ +files/dzip-2.9-system-zlib.patch, +dzip-2.9-r2.ebuild:
+ Use system zlib, bug #251109
06 Dec 2008; Tristan Heaven <nyhm@gentoo.org> dzip-2.9-r1.ebuild:
Respect CC, bug #244120
diff --git a/games-util/dzip/dzip-2.9-r2.ebuild b/games-util/dzip/dzip-2.9-r2.ebuild
new file mode 100644
index 000000000000..1ed47d7aff30
--- /dev/null
+++ b/games-util/dzip/dzip-2.9-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/dzip/dzip-2.9-r2.ebuild,v 1.1 2009/04/14 16:59:19 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="compressor/uncompressor for demo recordings from id's Quake"
+HOMEPAGE="http://speeddemosarchive.com/dzip/"
+SRC_URI="http://speeddemosarchive.com/dzip/dz${PV/./}src.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-system-zlib.patch \
+ "${FILESDIR}"/${P}-scrub-names.patch #93079
+ rm -rf zlib
+ mv -f Makefile{.linux,}
+}
+
+src_install () {
+ dogamesbin dzip || die "dogamesbin failed"
+ dodoc Readme || die "dodoc failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "Demo files can be found at http://planetquake.com/sda/"
+ elog "and http://planetquake.com/qdq/"
+ echo
+}
diff --git a/games-util/dzip/files/dzip-2.9-system-zlib.patch b/games-util/dzip/files/dzip-2.9-system-zlib.patch
new file mode 100644
index 000000000000..f68304adf240
--- /dev/null
+++ b/games-util/dzip/files/dzip-2.9-system-zlib.patch
@@ -0,0 +1,52 @@
+--- dzip.h
++++ dzip.h
+@@ -2,7 +2,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+
+-#include "zlib/zlib.h"
++#include <zlib.h>
+
+ typedef unsigned char uchar;
+
+@@ -177,4 +177,4 @@
+ #else
+ #define DIRCHAR '/'
+ #define WRONGCHAR '\\'
+-#endif
+\ No newline at end of file
++#endif
+--- Makefile.linux
++++ Makefile.linux
+@@ -1,18 +1,17 @@
+ # Makefile for linux
+
+-CC = gcc
+-CFLAGS = -Wall -O3
++CC ?= gcc
++CFLAGS ?= -O3
++CFLAGS += -Wall
+ TARGET = dzip
+ OBJECTS = main.o compress.o uncompress.o list.o crc32.o \
+- encode.o decode.o v1code.o conmain.o delete.o \
+- zlib/adler32.o zlib/deflate.o zlib/trees.o \
+- zlib/inflate.o zlib/infblock.o zlib/inftrees.o zlib/infcodes.o \
+- zlib/infutil.o zlib/inffast.o
++ encode.o decode.o v1code.o conmain.o delete.o
++LIBS = -lz
+
+ TMPFILES = gmon.out frag*
+
+ $(TARGET): $(OBJECTS)
+- $(CC) $(CFLAGS) $(OBJECTS) -o $(TARGET) $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJECTS) $(LIBS)
+
+ clean:
+ rm -f $(TARGET) $(OBJECTS) $(TMPFILES)
+@@ -24,4 +23,4 @@
+ encode.o: encode.c dzip.h
+ list.o: list.c dzip.h dzipcon.h
+ decode.o: decode.c dzip.h dzipcon.h
+-v1code.o: v1code.c dzip.h dzipcon.h
+\ No newline at end of file
++v1code.o: v1code.c dzip.h dzipcon.h