summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-07-14 12:34:22 +0000
committerPacho Ramos <pacho@gentoo.org>2011-07-14 12:34:22 +0000
commit16ccc8e19170ec4052a74b59d73c8c44e10b3c19 (patch)
tree5d108bda2cc99d970731bcf5b7c1dc93c22630b6 /gnome-base/gnome-panel
parentVersion bump, new snapshot (diff)
downloadgentoo-2-16ccc8e19170ec4052a74b59d73c8c44e10b3c19.tar.gz
gentoo-2-16ccc8e19170ec4052a74b59d73c8c44e10b3c19.tar.bz2
gentoo-2-16ccc8e19170ec4052a74b59d73c8c44e10b3c19.zip
Pass the correct month to Evolution command line from clock applet, thanks to walt for noticing.
(Portage version: 2.1.10.5/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/gnome-panel')
-rw-r--r--gnome-base/gnome-panel/ChangeLog9
-rw-r--r--gnome-base/gnome-panel/files/gnome-panel-2.32.1-evo-month.patch23
-rw-r--r--gnome-base/gnome-panel/gnome-panel-2.32.1-r3.ebuild118
3 files changed, 149 insertions, 1 deletions
diff --git a/gnome-base/gnome-panel/ChangeLog b/gnome-base/gnome-panel/ChangeLog
index 610f468f3298..fb2566e7ff0e 100644
--- a/gnome-base/gnome-panel/ChangeLog
+++ b/gnome-base/gnome-panel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/gnome-panel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/ChangeLog,v 1.335 2011/07/14 10:24:08 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/ChangeLog,v 1.336 2011/07/14 12:34:22 pacho Exp $
+
+*gnome-panel-2.32.1-r3 (14 Jul 2011)
+
+ 14 Jul 2011; Pacho Ramos <pacho@gentoo.org> +gnome-panel-2.32.1-r3.ebuild,
+ +files/gnome-panel-2.32.1-evo-month.patch:
+ Pass the correct month to Evolution command line from clock applet, thanks to
+ walt for noticing.
14 Jul 2011; Thomas Kahle <tomka@gentoo.org> gnome-panel-2.32.1-r2.ebuild:
x86 stable per bug 369909
diff --git a/gnome-base/gnome-panel/files/gnome-panel-2.32.1-evo-month.patch b/gnome-base/gnome-panel/files/gnome-panel-2.32.1-evo-month.patch
new file mode 100644
index 000000000000..531de79be316
--- /dev/null
+++ b/gnome-base/gnome-panel/files/gnome-panel-2.32.1-evo-month.patch
@@ -0,0 +1,23 @@
+From 241e288c0a9d30f9f2e8d608b0bbd950c1ac959c Mon Sep 17 00:00:00 2001
+From: Rodrigo Moya <rodrigo@gnome-db.org>
+Date: Mon, 02 May 2011 13:55:19 +0000
+Subject: clock applet: Pass the correct month to Evolution command line
+
+gtk_calendar_get_date returns the month between 0 and 11, so we need to add
+1 to the month being passed to Evolution
+---
+diff --git a/applets/clock/calendar-window.c b/applets/clock/calendar-window.c
+index c01bd6a..548b91b 100644
+--- a/applets/clock/calendar-window.c
++++ b/applets/clock/calendar-window.c
+@@ -1245,7 +1245,7 @@ calendar_day_activated (GtkCalendar *calendar,
+
+ argument = g_strdup_printf ("calendar:///?startdate="
+ "%.4d%.2d%.2d",
+- year, month, day);
++ year, month + 1, day);
+
+ clock_launch_calendar_app (calwin, argument);
+
+--
+cgit v0.9
diff --git a/gnome-base/gnome-panel/gnome-panel-2.32.1-r3.ebuild b/gnome-base/gnome-panel/gnome-panel-2.32.1-r3.ebuild
new file mode 100644
index 000000000000..ee3bbbf859fc
--- /dev/null
+++ b/gnome-base/gnome-panel/gnome-panel-2.32.1-r3.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-panel/gnome-panel-2.32.1-r3.ebuild,v 1.1 2011/07/14 12:34:22 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2:2.4"
+
+inherit gnome2 python eutils autotools
+
+DESCRIPTION="The GNOME panel"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="${SRC_URI} mirror://gentoo/introspection-20110205.m4.tar.bz2
+ http://dev.gentoo.org/~pacho/gnome/${P}-patches.tar.bz2"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+bonobo doc eds +introspection networkmanager"
+
+RDEPEND=">=gnome-base/gnome-desktop-2.26:2
+ >=x11-libs/pango-1.15.4[introspection?]
+ >=dev-libs/glib-2.25.12:2
+ >=x11-libs/gtk+-2.22:2[introspection?]
+ >=dev-libs/libgweather-2.27.90:2
+ dev-libs/libxml2:2
+ >=gnome-base/gconf-2.6.1:2[introspection?]
+ >=media-libs/libcanberra-0.23[gtk]
+ >=gnome-base/gnome-menus-2.27.92
+ gnome-base/librsvg:2
+ >=dev-libs/dbus-glib-0.80
+ >=sys-apps/dbus-1.1.2
+ >=x11-libs/cairo-1
+ x11-libs/libXau
+ >=x11-libs/libXrandr-1.2
+ bonobo? (
+ >=gnome-base/libbonobo-2.20.4
+ >=gnome-base/libbonoboui-2.1.1
+ >=gnome-base/orbit-2.4
+ >=x11-libs/libwnck-2.19.5:1 )
+ eds? ( >=gnome-extra/evolution-data-server-1.6 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+ networkmanager? ( >=net-misc/networkmanager-0.6.7 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ ~app-text/docbook-xml-dtd-4.1.2
+ doc? ( >=dev-util/gtk-doc-1 )
+ gnome-base/gnome-common
+ dev-util/gtk-doc-am"
+# eautoreconf needs
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-deprecation-flags
+ --disable-static
+ --disable-scrollkeeper
+ --disable-schemas-install
+ $(use_enable bonobo)
+ $(use_enable networkmanager network-manager)
+ $(use_enable introspection)
+ $(use_enable eds)"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ python_set_active_version 2
+}
+
+src_unpack() {
+ # If gobject-introspection is installed, we don't need the extra .m4
+ if has_version "dev-libs/gobject-introspection"; then
+ unpack ${P}.tar.bz2 ${P}-patches.tar.bz2
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # List the objects before the libraries to fix build with --as-needed
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ # Try to improve panel behavior on multiscreen systems, bug #348253, upstream #632369
+ epatch "${FILESDIR}/${PN}-2.32.1-fix-multiscreen.patch"
+ epatch "${FILESDIR}/${PN}-2.32.1-fix-multiscreen2.patch"
+
+ # Apply multiple bugfixes from 2.32 and master branches
+ # Also use gnome-applications.menu instead of applications.menu as it's the default value for us.
+ epatch "${WORKDIR}/${P}-patches"/*.patch
+
+ # clock applet: Pass the correct month to Evolution command line
+ epatch "${FILESDIR}/${PN}-2.32.1-evo-month.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ AT_M4DIR=${WORKDIR} eautoreconf
+}
+
+pkg_postinst() {
+ local entries="${EROOT}etc/gconf/schemas/panel-default-setup.entries"
+ local gconftool="${EROOT}usr/bin/gconftool-2"
+
+ if [ -e "$entries" ]; then
+ einfo "Setting panel gconf defaults..."
+
+ GCONF_CONFIG_SOURCE="$("${gconftool}" --get-default-source | sed "s;:/;:${ROOT};")"
+
+ "${gconftool}" --direct --config-source \
+ "${GCONF_CONFIG_SOURCE}" --load="${entries}"
+ fi
+
+ # Calling this late so it doesn't process the GConf schemas file we already
+ # took care of.
+ gnome2_pkg_postinst
+}