summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-01-22 20:53:43 +0000
committerPeter Volkov <pva@gentoo.org>2007-01-22 20:53:43 +0000
commitb20c33b5e1cb49823e6e7ba312b464fcba9a4726 (patch)
treef9263ffa50fa07750077946b88a397ce6b27cfe7 /gnome-base/gnome-vfs
parentFix HOMEPAGE (diff)
downloadgentoo-2-b20c33b5e1cb49823e6e7ba312b464fcba9a4726.tar.gz
gentoo-2-b20c33b5e1cb49823e6e7ba312b464fcba9a4726.tar.bz2
gentoo-2-b20c33b5e1cb49823e6e7ba312b464fcba9a4726.zip
Fixed gnome_vfs_url_show_with_env does not work if empty 'Path=' entry exists in *.desktop. Bug #161089.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'gnome-base/gnome-vfs')
-rw-r--r--gnome-base/gnome-vfs/ChangeLog10
-rw-r--r--gnome-base/gnome-vfs/files/digest-gnome-vfs-2.16.3-r13
-rw-r--r--gnome-base/gnome-vfs/files/gnome-vfs-2.16.3-empty-desktop-entry-Path.diff16
-rw-r--r--gnome-base/gnome-vfs/gnome-vfs-2.16.3-r1.ebuild95
4 files changed, 123 insertions, 1 deletions
diff --git a/gnome-base/gnome-vfs/ChangeLog b/gnome-base/gnome-vfs/ChangeLog
index 88de5bead5ef..44832aa7f453 100644
--- a/gnome-base/gnome-vfs/ChangeLog
+++ b/gnome-base/gnome-vfs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gnome-vfs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.241 2007/01/18 22:57:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.242 2007/01/22 20:53:43 pva Exp $
+
+*gnome-vfs-2.16.3-r1 (22 Jan 2007)
+
+ 22 Jan 2007; <pva@gentoo.org>
+ +files/gnome-vfs-2.16.3-empty-desktop-entry-Path.diff,
+ +gnome-vfs-2.16.3-r1.ebuild:
+ Fixed gnome_vfs_url_show_with_env does not work if empty 'Path=' entry
+ exists in *.desktop. Bug #161089.
18 Jan 2007; Jeroen Roovers <jer@gentoo.org> gnome-vfs-2.16.3.ebuild:
Stable for HPPA (bug #147751).
diff --git a/gnome-base/gnome-vfs/files/digest-gnome-vfs-2.16.3-r1 b/gnome-base/gnome-vfs/files/digest-gnome-vfs-2.16.3-r1
new file mode 100644
index 000000000000..11e08a39e511
--- /dev/null
+++ b/gnome-base/gnome-vfs/files/digest-gnome-vfs-2.16.3-r1
@@ -0,0 +1,3 @@
+MD5 586d6fe3740385c000a864d5e2cf8215 gnome-vfs-2.16.3.tar.bz2 1900424
+RMD160 9600bb4f4630d48600c1469fa5077d8e969a10cc gnome-vfs-2.16.3.tar.bz2 1900424
+SHA256 657df4d40dd1c8cbc9a266b9f38fea36019ef8a917eafcd3c38c840b8e9c7777 gnome-vfs-2.16.3.tar.bz2 1900424
diff --git a/gnome-base/gnome-vfs/files/gnome-vfs-2.16.3-empty-desktop-entry-Path.diff b/gnome-base/gnome-vfs/files/gnome-vfs-2.16.3-empty-desktop-entry-Path.diff
new file mode 100644
index 000000000000..1bda6cdc1d4d
--- /dev/null
+++ b/gnome-base/gnome-vfs/files/gnome-vfs-2.16.3-empty-desktop-entry-Path.diff
@@ -0,0 +1,16 @@
+diff -Naur gnome-vfs-2.16.3.ori/libgnomevfs/gnome-vfs-mime-handlers.c gnome-vfs-2.16.3/libgnomevfs/gnome-vfs-mime-handlers.c
+--- gnome-vfs-2.16.3.ori/libgnomevfs/gnome-vfs-mime-handlers.c 2006-11-20 10:44:13.000000000 +0300
++++ gnome-vfs-2.16.3/libgnomevfs/gnome-vfs-mime-handlers.c 2006-12-25 16:44:11.000000000 +0300
+@@ -1423,6 +1423,12 @@
+ app->priv->path = g_key_file_get_string (key_file, DESKTOP_ENTRY_GROUP,
+ "Path", NULL);
+
++ /* 'Path=' .desktop item is not working. bugzilla.gnome.org/389273 */
++ if (app->priv->path != NULL && *app->priv->path == 0) {
++ g_free (app->priv->path);
++ app->priv->path = NULL;
++ }
++
+ app->requires_terminal = g_key_file_get_boolean
+ (key_file, DESKTOP_ENTRY_GROUP, "Terminal", &err);
+ if (err) {
diff --git a/gnome-base/gnome-vfs/gnome-vfs-2.16.3-r1.ebuild b/gnome-base/gnome-vfs/gnome-vfs-2.16.3-r1.ebuild
new file mode 100644
index 000000000000..bc5cf71e3538
--- /dev/null
+++ b/gnome-base/gnome-vfs/gnome-vfs-2.16.3-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/gnome-vfs-2.16.3-r1.ebuild,v 1.1 2007/01/22 20:53:43 pva Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=1.9
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Gnome Virtual Filesystem"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="avahi doc gnutls hal ipv6 samba ssl"
+
+RDEPEND=">=gnome-base/gconf-2
+ >=dev-libs/glib-2.9.3
+ >=gnome-base/orbit-2.12.4
+ >=dev-libs/libxml2-2.6
+ >=net-misc/neon-0.25.3
+ app-arch/bzip2
+ virtual/fam
+ gnome-base/gnome-mime-data
+ >=x11-misc/shared-mime-info-0.14
+ || ( >=dev-libs/dbus-glib-0.71 <sys-apps/dbus-0.90 )
+ samba? ( >=net-fs/samba-3 )
+ gnutls? (
+ net-libs/gnutls
+ !gnome-extra/gnome-vfs-sftp
+ )
+ ssl? (
+ !gnutls? (
+ >=dev-libs/openssl-0.9.5
+ !gnome-extra/gnome-vfs-sftp
+ )
+ )
+ hal? (
+ >=sys-apps/hal-0.5.7
+ )
+ avahi? ( >=net-dns/avahi-0.6 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+PDEPEND="hal? ( >=gnome-base/gnome-mount-0.4 )"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+
+pkg_setup() {
+ if use hal ; then
+ G2CONF="--with-hal-mount=/usr/bin/gnome-mount \
+ --with-hal-umount=/usr/bin/gnome-umount \
+ --with-hal-eject=/usr/bin/gnome-eject"
+ fi
+
+ G2CONF="${G2CONF} \
+ --disable-schemas-install \
+ --disable-cdda \
+ --disable-howl \
+ --enable-http-neon \
+ $(use_enable ssl openssl) \
+ $(use_enable gnutls) \
+ $(use_enable samba) \
+ $(use_enable ipv6) \
+ $(use_enable hal) \
+ $(use_enable avahi)"
+
+ # this works because of the order of conifgure parsing
+ # so should always be behind the use_enable options
+ # foser <foser@gentoo.org 19 Apr 2004
+ use gnutls && use ssl && G2CONF="${G2CONF} --disable-openssl"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Allow the Trash on afs filesystems (#106118)
+ epatch "${FILESDIR}"/${PN}-2.12.0-afs.patch
+
+ # Fix compiling with headers missing
+ epatch "${FILESDIR}"/${PN}-2.15.2-headers-define.patch
+
+ # Fix for crashes running programs via sudo
+ epatch "${FILESDIR}"/${PN}-2.16.0-no-dbus-crash.patch
+
+ # Fix gnome_vfs_url_show_with_env with 'Path=' in .desktop (bug 161089)
+ epatch "${FILESDIR}"/${P}-empty-desktop-entry-Path.diff
+
+ # For gtk-doc macro failure when it's not installed
+ cp aclocal.m4 old_macros.m4
+ AT_M4DIR="."
+ eautoreconf
+}