summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-25 18:37:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-25 18:37:35 +0000
commit9c8ab475492086e4c6285cf9d113385ef1e63d75 (patch)
tree0c6b72f809de9ba102cba6c0c2dd7021818d6c84 /kde-base/konq-plugins
parentUnmask KDE 3.5.6, let's the bugs flow. (diff)
downloadgentoo-2-9c8ab475492086e4c6285cf9d113385ef1e63d75.tar.gz
gentoo-2-9c8ab475492086e4c6285cf9d113385ef1e63d75.tar.bz2
gentoo-2-9c8ab475492086e4c6285cf9d113385ef1e63d75.zip
Add a patch to fix a privacy issue with the archiver.
(Portage version: 2.1.2-r3)
Diffstat (limited to 'kde-base/konq-plugins')
-rw-r--r--kde-base/konq-plugins/ChangeLog10
-rw-r--r--kde-base/konq-plugins/files/digest-konq-plugins-3.5.5-r13
-rw-r--r--kde-base/konq-plugins/files/digest-konq-plugins-3.5.6-r13
-rw-r--r--kde-base/konq-plugins/files/konq-plugins-3.5-archiver.patch37
-rw-r--r--kde-base/konq-plugins/konq-plugins-3.5.5-r1.ebuild22
-rw-r--r--kde-base/konq-plugins/konq-plugins-3.5.6-r1.ebuild22
6 files changed, 96 insertions, 1 deletions
diff --git a/kde-base/konq-plugins/ChangeLog b/kde-base/konq-plugins/ChangeLog
index 76971db1043e..13efcb3df611 100644
--- a/kde-base/konq-plugins/ChangeLog
+++ b/kde-base/konq-plugins/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/konq-plugins
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/konq-plugins/ChangeLog,v 1.64 2007/01/16 20:59:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/konq-plugins/ChangeLog,v 1.65 2007/01/25 18:37:35 flameeyes Exp $
+
+*konq-plugins-3.5.6-r1 (25 Jan 2007)
+*konq-plugins-3.5.5-r1 (25 Jan 2007)
+
+ 25 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +files/konq-plugins-3.5-archiver.patch, +konq-plugins-3.5.5-r1.ebuild,
+ +konq-plugins-3.5.6-r1.ebuild:
+ Add a patch to fix a privacy issue with the archiver.
*konq-plugins-3.5.6 (16 Jan 2007)
diff --git a/kde-base/konq-plugins/files/digest-konq-plugins-3.5.5-r1 b/kde-base/konq-plugins/files/digest-konq-plugins-3.5.5-r1
new file mode 100644
index 000000000000..16b8b41f83cd
--- /dev/null
+++ b/kde-base/konq-plugins/files/digest-konq-plugins-3.5.5-r1
@@ -0,0 +1,3 @@
+MD5 71c0a690abf8ad0f43135fa887d0b40c kdeaddons-3.5.5.tar.bz2 1663195
+RMD160 4a8e43e3268dc687de049482be57e1372a6abea3 kdeaddons-3.5.5.tar.bz2 1663195
+SHA256 1db58293a8b967d254a39c9bdb0c5dfb3759a7d067280dd3d637e2423beb632c kdeaddons-3.5.5.tar.bz2 1663195
diff --git a/kde-base/konq-plugins/files/digest-konq-plugins-3.5.6-r1 b/kde-base/konq-plugins/files/digest-konq-plugins-3.5.6-r1
new file mode 100644
index 000000000000..055b06166548
--- /dev/null
+++ b/kde-base/konq-plugins/files/digest-konq-plugins-3.5.6-r1
@@ -0,0 +1,3 @@
+MD5 96d6d2a76da2a5232b3b46318456a5bc kdeaddons-3.5.6.tar.bz2 1667731
+RMD160 3fd024b901896cc76a848ab57eb3e2ae99b6a202 kdeaddons-3.5.6.tar.bz2 1667731
+SHA256 dec71f341631beb1f3e112083af11e3ef1618ed80394cf4939c662f8c5a3d807 kdeaddons-3.5.6.tar.bz2 1667731
diff --git a/kde-base/konq-plugins/files/konq-plugins-3.5-archiver.patch b/kde-base/konq-plugins/files/konq-plugins-3.5-archiver.patch
new file mode 100644
index 000000000000..441567df1b2f
--- /dev/null
+++ b/kde-base/konq-plugins/files/konq-plugins-3.5-archiver.patch
@@ -0,0 +1,37 @@
+------------------------------------------------------------------------
+r626814 | mueller | 2007-01-24 18:16:52 +0100 (Wed, 24 Jan 2007) | 5 lines
+Changed paths:
+ M /branches/KDE/3.5/kdeaddons/konq-plugins/webarchiver/archivedialog.cpp
+ M /branches/KDE/3.5/kdeaddons/konq-plugins/webarchiver/webarchivecreator.cpp
+
+fix a minor but annoying privacy issue: the web archiver
+would happily put local files or other launch other unsafe
+protocols if referenced in the website, even though konqueror
+itself wouldn't handle it
+
+------------------------------------------------------------------------
+Index: konq-plugins/webarchiver/archivedialog.cpp
+===================================================================
+--- konq-plugins/webarchiver/archivedialog.cpp (revision 626813)
++++ konq-plugins/webarchiver/archivedialog.cpp (revision 626814)
+@@ -395,12 +395,15 @@ void ArchiveDialog::saveArchiveRecursive
+ QString ArchiveDialog::handleLink(const KURL& _url, const QString& _link)
+ {
+ KURL url(getAbsoluteURL(_url, _link));
+- QString tarFileName;
+
+- if (m_state==Retrieving)
+- m_urlsToDownload.append(url);
+- else if (m_state==Saving)
+- tarFileName = m_downloadedURLDict[url.url()];
++ QString tarFileName;
++ if (kapp->authorizeURLAction("redirect", _url, url))
++ {
++ if (m_state==Retrieving)
++ m_urlsToDownload.append(url);
++ else if (m_state==Saving)
++ tarFileName = m_downloadedURLDict[url.url()];
++ }
+
+ return tarFileName;
+ }
diff --git a/kde-base/konq-plugins/konq-plugins-3.5.5-r1.ebuild b/kde-base/konq-plugins/konq-plugins-3.5.5-r1.ebuild
new file mode 100644
index 000000000000..71670faed355
--- /dev/null
+++ b/kde-base/konq-plugins/konq-plugins-3.5.5-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/konq-plugins/konq-plugins-3.5.5-r1.ebuild,v 1.1 2007/01/25 18:37:35 flameeyes Exp $
+
+KMNAME=kdeaddons
+KMNODOCS=true
+MAXKDEVER=$PV
+inherit kde-meta
+
+DESCRIPTION="Various plugins for Konqueror."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="$(deprange-dual $PV $MAXKDEVER kde-base/konqueror)
+ !kde-misc/metabar"
+RDEPEND="${DEPEND}
+$(deprange 3.5.4 $MAXKDEVER kde-base/kdeaddons-docs-konq-plugins)"
+
+# Don't install the akregator plugin, since it depends on akregator, which is
+# a heavy dep.
+KMEXTRACTONLY="konq-plugins/akregator"
+
+PATCHES="${FILESDIR}/konq-plugins-3.5-archiver.patch"
diff --git a/kde-base/konq-plugins/konq-plugins-3.5.6-r1.ebuild b/kde-base/konq-plugins/konq-plugins-3.5.6-r1.ebuild
new file mode 100644
index 000000000000..bcec181e849c
--- /dev/null
+++ b/kde-base/konq-plugins/konq-plugins-3.5.6-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/konq-plugins/konq-plugins-3.5.6-r1.ebuild,v 1.1 2007/01/25 18:37:35 flameeyes Exp $
+
+KMNAME=kdeaddons
+KMNODOCS=true
+MAXKDEVER=$PV
+inherit kde-meta
+
+DESCRIPTION="Various plugins for Konqueror."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="$(deprange-dual $PV $MAXKDEVER kde-base/konqueror)
+ !kde-misc/metabar"
+RDEPEND="${DEPEND}
+$(deprange 3.5.4 $MAXKDEVER kde-base/kdeaddons-docs-konq-plugins)"
+
+# Don't install the akregator plugin, since it depends on akregator, which is
+# a heavy dep.
+KMEXTRACTONLY="konq-plugins/akregator"
+
+PATCHES="${FILESDIR}/konq-plugins-3.5-archiver.patch"