summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2012-11-08 23:27:13 +0000
committerChris Reffett <creffett@gentoo.org>2012-11-08 23:27:13 +0000
commit8447a20009e6eaf131d2dc2a174edca000e5ecf3 (patch)
treef043646d02ff070d4c0b47476d88f93c018958b6 /kde-base/ksplash
parentremove old versions (diff)
downloadgentoo-2-8447a20009e6eaf131d2dc2a174edca000e5ecf3.tar.gz
gentoo-2-8447a20009e6eaf131d2dc2a174edca000e5ecf3.tar.bz2
gentoo-2-8447a20009e6eaf131d2dc2a174edca000e5ecf3.zip
Version bump KDE SC 4.9.3
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.9.3.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 8f5457ca01f4..dbb1e6a6ee4a 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.143 2012/10/17 18:40:40 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.144 2012/11/08 23:26:56 creffett Exp $
+
+*ksplash-4.9.3 (08 Nov 2012)
+
+ 08 Nov 2012; <creffett@gentoo.org> +ksplash-4.9.3.ebuild:
+ Version bump KDE SC 4.9.3
17 Oct 2012; Markus Meier <maekke@gentoo.org> ksplash-4.9.2.ebuild:
add ~arm, bug #430072
diff --git a/kde-base/ksplash/ksplash-4.9.3.ebuild b/kde-base/ksplash/ksplash-4.9.3.ebuild
new file mode 100644
index 000000000000..ba58f9e99fa8
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.9.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.9.3.ebuild,v 1.1 2012/11/08 23:26:56 creffett Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama)
+ )
+
+ kde4-meta_src_configure
+}