summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-25 08:40:36 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-25 08:40:36 +0000
commit188d0d891ce81b5aa27e437d808547ab845f1a7a (patch)
tree5308ecf00cb7862ce79a52e5c5529332815fa7e2 /media-libs/openquicktime
parentAdding a masked out libglade to go along with pygtk2 and other cute things (diff)
downloadgentoo-2-188d0d891ce81b5aa27e437d808547ab845f1a7a.tar.gz
gentoo-2-188d0d891ce81b5aa27e437d808547ab845f1a7a.tar.bz2
gentoo-2-188d0d891ce81b5aa27e437d808547ab845f1a7a.zip
New package
Diffstat (limited to 'media-libs/openquicktime')
-rw-r--r--media-libs/openquicktime/ChangeLog14
-rw-r--r--media-libs/openquicktime/files/digest-openquicktime-1.01
-rw-r--r--media-libs/openquicktime/openquicktime-1.0.ebuild36
3 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/openquicktime/ChangeLog b/media-libs/openquicktime/ChangeLog
new file mode 100644
index 000000000000..50842b092c16
--- /dev/null
+++ b/media-libs/openquicktime/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for media-libs/openquicktime
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openquicktime/ChangeLog,v 1.1 2002/04/25 08:40:36 rphillips Exp $
+
+*openquicktime-1.0 (25 Apr 2002)
+
+ 25 Apr 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
diff --git a/media-libs/openquicktime/files/digest-openquicktime-1.0 b/media-libs/openquicktime/files/digest-openquicktime-1.0
new file mode 100644
index 000000000000..d08e2560574d
--- /dev/null
+++ b/media-libs/openquicktime/files/digest-openquicktime-1.0
@@ -0,0 +1 @@
+MD5 f90bc78b8632c6c254cddf70b4726644 openquicktime-1.0-src.tgz 320144
diff --git a/media-libs/openquicktime/openquicktime-1.0.ebuild b/media-libs/openquicktime/openquicktime-1.0.ebuild
new file mode 100644
index 000000000000..4f2f45fd87c8
--- /dev/null
+++ b/media-libs/openquicktime/openquicktime-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Ryan Phillips <rphillips@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openquicktime/openquicktime-1.0.ebuild,v 1.1 2002/04/25 08:40:36 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="OpenQuicktime library for linux"
+SRC_URI="http://prdownloads.sourceforge.net/openquicktime/${P}-src.tgz"
+HOMEPAGE="http://openquicktime.sourceforge.net/"
+
+DEPEND="media-sound/lame
+ media-sound/mpg123
+ media-libs/jpeg"
+
+src_compile() {
+ cd ${S}-src
+
+ ./configure \
+ --enable-debug=no \ # Disable debug - enabled by default
+ --prefix=/usr || die
+
+ make || die
+}
+
+src_install() {
+ cd ${S}-src
+ dolib.so libopenquicktime.so
+ dodoc README AUTHORS NEWS COPYING TODO
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF}/html \
+ sysconfdir=${D}/etc \
+ install || die
+}