summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-01-05 10:30:18 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-01-05 10:30:18 +0000
commitc89e438320b8dff1849fd5d7131091fc37b02fdf (patch)
tree4926a9c8e536f48da50be308827b3af43a3eb59a /media-sound/audacious
parentDeveloper release of the new 1.3 series. File bugs upstream at http://bugs-me... (diff)
downloadgentoo-2-c89e438320b8dff1849fd5d7131091fc37b02fdf.tar.gz
gentoo-2-c89e438320b8dff1849fd5d7131091fc37b02fdf.tar.bz2
gentoo-2-c89e438320b8dff1849fd5d7131091fc37b02fdf.zip
Developer release of the new 1.3 series. File bugs upstream at http://bugs-meta.atheme.org/ and not in the Gentoo bug tracker. Major changes in playlist handling and file scanning. Closes bug #156639, with thanks to Chris Kehler <cbkehler@sympatico.ca>.
(Portage version: 2.1.2_rc3-r9)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog13
-rw-r--r--media-sound/audacious/audacious-1.3.0_alpha1.ebuild54
-rw-r--r--media-sound/audacious/files/digest-audacious-1.3.0_alpha16
3 files changed, 71 insertions, 2 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 4e945a2b1f16..fad559e7a589 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-sound/audacious
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.96 2006/12/05 14:57:26 jer Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.97 2007/01/05 10:30:18 chainsaw Exp $
+
+*audacious-1.3.0_alpha1 (05 Jan 2007)
+
+ 05 Jan 2007; Tony Vroon <chainsaw@gentoo.org>
+ +audacious-1.3.0_alpha1.ebuild:
+ Developer release of the new 1.3 series. File bugs upstream at
+ http://bugs-meta.atheme.org/ and not in the Gentoo bug tracker. Major
+ changes in playlist handling and file scanning. Closes bug #156639, with
+ thanks to Chris Kehler <cbkehler@sympatico.ca>.
05 Dec 2006; Jeroen Roovers <jer@gentoo.org> audacious-1.2.2.ebuild:
Stable for HPPA.
diff --git a/media-sound/audacious/audacious-1.3.0_alpha1.ebuild b/media-sound/audacious/audacious-1.3.0_alpha1.ebuild
new file mode 100644
index 000000000000..272f18bc2bc2
--- /dev/null
+++ b/media-sound/audacious/audacious-1.3.0_alpha1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.3.0_alpha1.ebuild,v 1.1 2007/01/05 10:30:18 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/release/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="chardet nls gnome"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ dev-libs/libxml2
+ gnome? ( >=gnome-base/gconf-2.6.0 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.3.0_alpha1"
+
+src_compile() {
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable gnome gconf) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}
diff --git a/media-sound/audacious/files/digest-audacious-1.3.0_alpha1 b/media-sound/audacious/files/digest-audacious-1.3.0_alpha1
new file mode 100644
index 000000000000..285723a315dd
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-1.3.0_alpha1
@@ -0,0 +1,6 @@
+MD5 037ddc1b36d104af4979b599ba01c32c audacious-1.3.0-alpha1.tgz 1791152
+RMD160 1f12cc2c4def13148b3f5cc233b4663ae2eacc26 audacious-1.3.0-alpha1.tgz 1791152
+SHA256 1dbabe4a6c676194fb3235930e13c5a6e34eb50baf6dff99416a3f9bdf5afdd8 audacious-1.3.0-alpha1.tgz 1791152
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839