summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Huebel <jhuebel@gentoo.org>2004-04-01 14:23:35 +0000
committerJason Huebel <jhuebel@gentoo.org>2004-04-01 14:23:35 +0000
commit27c3ab3b1fd9b04dae68ab57f1f4dd5b9b9ad626 (patch)
tree2790e4bee8b642b21d0b7a2742a41bf11e2546d5 /media-sound/grip
parentlib64 fix on amd64 (Manifest recommit) (diff)
downloadgentoo-2-27c3ab3b1fd9b04dae68ab57f1f4dd5b9b9ad626.tar.gz
gentoo-2-27c3ab3b1fd9b04dae68ab57f1f4dd5b9b9ad626.tar.bz2
gentoo-2-27c3ab3b1fd9b04dae68ab57f1f4dd5b9b9ad626.zip
patch for AMD64 SMP crash, submitted by Brian Silverthorn <bcs26@cornell.edu>
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/ChangeLog6
-rw-r--r--media-sound/grip/files/grip-3.1.8-statuscheck-lp64.patch11
-rw-r--r--media-sound/grip/grip-3.1.8.ebuild10
3 files changed, 25 insertions, 2 deletions
diff --git a/media-sound/grip/ChangeLog b/media-sound/grip/ChangeLog
index cdf23d584f9f..3694967e0706 100644
--- a/media-sound/grip/ChangeLog
+++ b/media-sound/grip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/grip
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.30 2004/03/30 17:57:27 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.31 2004/04/01 14:23:30 jhuebel Exp $
+
+ 01 Apr 2004; Jason Eric Huebel <jhuebel@gentoo.org> grip-3.1.8.ebuild,
+ files/grip-3.1.8-statuscheck-lp64.patch:
+ patch for AMD64 SMP crash, submitted by Brian Silverthorn <bcs26@cornell.edu>
*grip-3.1.8 (30 Mar 2004)
diff --git a/media-sound/grip/files/grip-3.1.8-statuscheck-lp64.patch b/media-sound/grip/files/grip-3.1.8-statuscheck-lp64.patch
new file mode 100644
index 000000000000..6dfd24914586
--- /dev/null
+++ b/media-sound/grip/files/grip-3.1.8-statuscheck-lp64.patch
@@ -0,0 +1,11 @@
+--- grip-3.1.4-orig/src/status_window.c 2004-02-14 01:21:01.193001784 -0500
++++ grip-3.1.4/src/status_window.c 2004-02-14 01:19:32.069550608 -0500
+@@ -83,7 +83,7 @@
+ void StatusWindowWrite(StatusWindow *sw,char *msg)
+ {
+ char *buf, *locale_msg;
+- int len;
++ gsize len;
+ int pos=0;
+
+ /* gtk_widget_queue_resize(sw->term_widget);*/
diff --git a/media-sound/grip/grip-3.1.8.ebuild b/media-sound/grip/grip-3.1.8.ebuild
index 11aa91870281..b0f5d0bc991e 100644
--- a/media-sound/grip/grip-3.1.8.ebuild
+++ b/media-sound/grip/grip-3.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-3.1.8.ebuild,v 1.1 2004/03/30 17:57:27 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-3.1.8.ebuild,v 1.2 2004/04/01 14:23:30 jhuebel Exp $
inherit eutils
@@ -26,6 +26,14 @@ IUSE="nls oggvorbis"
SLOT="0"
KEYWORDS="~x86 ~ppc alpha ~amd64 ~hppa ~sparc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # AMD64 SMP Crash Fix, submitted by Brian Silverthorn <bcs26@cornell.edu>
+ epatch ${FILESDIR}/${P}-statuscheck-lp64.patch
+}
+
src_compile() {
econf --disable-dependency-tracking `use_enable nls` || die
emake || die "emake failed"