summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-06-21 17:23:30 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-06-21 17:23:30 +0000
commit0496daec1b9aa98b74399952fa9be470fdcf5412 (patch)
tree5c495a1d894c0b75e4cc6caebeff25a2327298be /media-sound
parentstable x86, bug 319473 (diff)
downloadgentoo-2-0496daec1b9aa98b74399952fa9be470fdcf5412.tar.gz
gentoo-2-0496daec1b9aa98b74399952fa9be470fdcf5412.tar.bz2
gentoo-2-0496daec1b9aa98b74399952fa9be470fdcf5412.zip
Add live version ebuild. With kind permission of ssuominen.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qmpdclient/ChangeLog8
-rw-r--r--media-sound/qmpdclient/qmpdclient-9999.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/media-sound/qmpdclient/ChangeLog b/media-sound/qmpdclient/ChangeLog
index 48b15626ea9a..72fe1224cd1e 100644
--- a/media-sound/qmpdclient/ChangeLog
+++ b/media-sound/qmpdclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/qmpdclient
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/ChangeLog,v 1.65 2010/06/03 17:42:45 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/ChangeLog,v 1.66 2010/06/21 17:23:30 scarabeus Exp $
+
+*qmpdclient-9999 (21 Jun 2010)
+
+ 21 Jun 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +qmpdclient-9999.ebuild:
+ Add live version ebuild. With kind permission of ssuominen.
*qmpdclient-1.1.3 (03 Jun 2010)
diff --git a/media-sound/qmpdclient/qmpdclient-9999.ebuild b/media-sound/qmpdclient/qmpdclient-9999.ebuild
new file mode 100644
index 000000000000..a44d09819469
--- /dev/null
+++ b/media-sound/qmpdclient/qmpdclient-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/qmpdclient-9999.ebuild,v 1.1 2010/06/21 17:23:30 scarabeus Exp $
+
+EAPI=3
+
+inherit cmake-utils git
+
+DESCRIPTION="QMPDClient with NBL additions, such as lyrics' display"
+HOMEPAGE="http://bitcheese.net/wiki/QMPDClient"
+#SRC_URI="http://dump.bitcheese.net/files/${P}.tar.bz2"
+EGIT_REPO_URI="http://github.com/Voker57/qmpdclient.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+DEPEND="
+ x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-xmlpatterns:4
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+DOCS="AUTHORS README THANKSTO Changelog"
+
+src_configure() {
+ mycmakeargs=( "-DVERSION=${PV}" )
+ cmake-utils_src_configure
+}