summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-16 05:40:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-16 05:40:14 +0000
commit77dfc3d82cb47e2a2c171bc2c435db6e5da85b98 (patch)
tree88b434b5d0f6f5e7487f4653c945dd08d6076fc8 /media-video/clive
parentversion bump (diff)
downloadgentoo-2-77dfc3d82cb47e2a2c171bc2c435db6e5da85b98.tar.gz
gentoo-2-77dfc3d82cb47e2a2c171bc2c435db6e5da85b98.tar.bz2
gentoo-2-77dfc3d82cb47e2a2c171bc2c435db6e5da85b98.zip
version bump
(Portage version: 2.1.5)
Diffstat (limited to 'media-video/clive')
-rw-r--r--media-video/clive/ChangeLog7
-rw-r--r--media-video/clive/clive-0.4.12.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index 7f901c8d1fd4..eadc4ffdda65 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.20 2008/05/11 23:14:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.21 2008/05/16 05:40:14 aballier Exp $
+
+*clive-0.4.12 (16 May 2008)
+
+ 16 May 2008; Alexis Ballier <aballier@gentoo.org> +clive-0.4.12.ebuild:
+ version bump
11 May 2008; Alexis Ballier <aballier@gentoo.org> -clive-0.4.6.ebuild:
remove old
diff --git a/media-video/clive/clive-0.4.12.ebuild b/media-video/clive/clive-0.4.12.ebuild
new file mode 100644
index 000000000000..79c80e7dd71f
--- /dev/null
+++ b/media-video/clive/clive-0.4.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-0.4.12.ebuild,v 1.1 2008/05/16 05:40:14 aballier Exp $
+
+# We inherit distutils to get the pkg_* functions for byte compiling python
+inherit versionator distutils
+
+DESCRIPTION="Command line tool for extracting videos from Youtube, Google Video, Dailymotion, Guba (free) and Stage6 websites"
+HOMEPAGE="http://home.gna.org/clive/"
+SRC_URI="http://dl.gna.org/clive/$(get_version_component_range 1-2 ${PV})/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=dev-libs/newt-0.51
+ >=dev-python/urlgrabber-3.1.0
+ >=dev-python/feedparser-4.1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ # with-lib means compile its own
+ econf $(use_with doc) \
+ --without-newt \
+ --without-feedparser \
+ --without-urlgrabber
+ emake || die "emake failed"
+ if use doc; then
+ emake dox || die "failed to create the documentation"
+ fi
+}
+
+src_install() {
+ emake py_compile=true DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog README
+ use doc && dohtml dox/html/*
+}