summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-04-21 15:04:20 +0000
committerHanno Böck <hanno@gentoo.org>2006-04-21 15:04:20 +0000
commit289e51360e32cab74fc6d97fc1c8c55a4f55b843 (patch)
tree4c6240aef198678ef97f077d5f24956b7fe6b5ab /media-video/thoggen
parentremove mask for bmpx USE flag as it is now unmasked (diff)
downloadgentoo-2-289e51360e32cab74fc6d97fc1c8c55a4f55b843.tar.gz
gentoo-2-289e51360e32cab74fc6d97fc1c8c55a4f55b843.tar.bz2
gentoo-2-289e51360e32cab74fc6d97fc1c8c55a4f55b843.zip
thoggen version bump
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'media-video/thoggen')
-rw-r--r--media-video/thoggen/ChangeLog7
-rw-r--r--media-video/thoggen/files/digest-thoggen-0.4.23
-rw-r--r--media-video/thoggen/thoggen-0.4.2.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/media-video/thoggen/ChangeLog b/media-video/thoggen/ChangeLog
index c6856ba76e15..94692e81a675 100644
--- a/media-video/thoggen/ChangeLog
+++ b/media-video/thoggen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/thoggen
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/thoggen/ChangeLog,v 1.8 2006/04/01 13:21:15 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/thoggen/ChangeLog,v 1.9 2006/04/21 15:04:19 hanno Exp $
+
+*thoggen-0.4.2 (21 Apr 2006)
+
+ 21 Apr 2006; Hanno Boeck <hanno@gentoo.org> +thoggen-0.4.2.ebuild:
+ Version bump.
01 Apr 2006; Hanno Boeck <hanno@gentoo.org>
+files/thoggen-0.4.1-libdvdread.diff, thoggen-0.4.1.ebuild:
diff --git a/media-video/thoggen/files/digest-thoggen-0.4.2 b/media-video/thoggen/files/digest-thoggen-0.4.2
new file mode 100644
index 000000000000..4b343aebcaa4
--- /dev/null
+++ b/media-video/thoggen/files/digest-thoggen-0.4.2
@@ -0,0 +1,3 @@
+MD5 5b47e279a693ffd34b311f2f5e035ec2 thoggen-0.4.2.tar.gz 775405
+RMD160 bc0980882e3989f1af31e0ca3d49bdcfbec2a9fb thoggen-0.4.2.tar.gz 775405
+SHA256 b58808d6281d85e477dac7d27dd5e57bd1392196be5bb6664e607b511349f359 thoggen-0.4.2.tar.gz 775405
diff --git a/media-video/thoggen/thoggen-0.4.2.ebuild b/media-video/thoggen/thoggen-0.4.2.ebuild
new file mode 100644
index 000000000000..a956c3f3bce0
--- /dev/null
+++ b/media-video/thoggen/thoggen-0.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/thoggen/thoggen-0.4.2.ebuild,v 1.1 2006/04/21 15:04:19 hanno Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="DVD ripper, based on GStreamer and Gtk+"
+HOMEPAGE="http://thoggen.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dts"
+
+DEPEND=">=dev-libs/glib-2.6.0
+ >=x11-libs/gtk+-2.6.0
+ >=gnome-base/libglade-2.4.0
+ =media-libs/gstreamer-0.8*
+ =media-libs/gst-plugins-0.8*
+ =media-plugins/gst-plugins-mpeg2dec-0.8*
+ =media-plugins/gst-plugins-a52dec-0.8*
+ =media-plugins/gst-plugins-dvdread-0.8*
+ =media-plugins/gst-plugins-theora-0.8*
+ =media-plugins/gst-plugins-vorbis-0.8*
+ =media-plugins/gst-plugins-ogg-0.8*
+ dts? ( =media-plugins/gst-plugins-dts-0.8* )
+ >=sys-apps/dbus-0.23
+ >=sys-apps/hal-0.4
+ >=media-libs/libdvdread-0.9.4"
+
+pkg_setup() {
+ if ! built_with_use sys-apps/dbus gtk; then
+ eerror "Please merge sys-apps/dbus with 'gtk' in USE flags."
+ die "Need glib support in dbus!"
+ fi
+}
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+# needed to get around some sandboxing checks
+export GST_INSPECT=/bin/true