summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-11-02 12:35:01 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-11-02 12:35:01 +0000
commit7429a2f54480513c9255ebe3d2f1f6ca8b1aa3c9 (patch)
tree81ba51125dae61111fc8d95bb82c96dd80159f7f /media-video
parentnet-fs/netatalk: Version Bump, #489756 (diff)
downloadgentoo-2-7429a2f54480513c9255ebe3d2f1f6ca8b1aa3c9.tar.gz
gentoo-2-7429a2f54480513c9255ebe3d2f1f6ca8b1aa3c9.tar.bz2
gentoo-2-7429a2f54480513c9255ebe3d2f1f6ca8b1aa3c9.zip
Version bump. Bug #489634
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/minitube/ChangeLog11
-rw-r--r--media-video/minitube/files/minitube-2.1.3-disable-updates.patch13
-rw-r--r--media-video/minitube/minitube-2.1.3.ebuild61
3 files changed, 84 insertions, 1 deletions
diff --git a/media-video/minitube/ChangeLog b/media-video/minitube/ChangeLog
index 877c56e79565..77d40d37d920 100644
--- a/media-video/minitube/ChangeLog
+++ b/media-video/minitube/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/minitube
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/ChangeLog,v 1.88 2013/06/29 07:34:34 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/ChangeLog,v 1.89 2013/11/02 12:35:00 hwoarang Exp $
+
+*minitube-2.1.3 (02 Nov 2013)
+*minitube-2.1 (02 Nov 2013)
+
+ 02 Nov 2013; Markos Chandras <hwoarang@gentoo.org>
+ +files/minitube-2.1-disable-updates.patch,
+ +files/minitube-2.1.3-disable-updates.patch, +minitube-2.1.3.ebuild,
+ +minitube-2.1.ebuild:
+ Version bump. Bug #489634
29 Jun 2013; Michael Palimaka <kensington@gentoo.org>
-files/minitube-1.9-desktop.patch, -minitube-1.9.ebuild:
diff --git a/media-video/minitube/files/minitube-2.1.3-disable-updates.patch b/media-video/minitube/files/minitube-2.1.3-disable-updates.patch
new file mode 100644
index 000000000000..869850a5c6e5
--- /dev/null
+++ b/media-video/minitube/files/minitube-2.1.3-disable-updates.patch
@@ -0,0 +1,13 @@
+Index: minitube/src/mainwindow.cpp
+===================================================================
+--- minitube.orig/src/mainwindow.cpp
++++ minitube/src/mainwindow.cpp
+@@ -197,8 +197,6 @@ void MainWindow::lazyInit() {
+
+ JsFunctions::instance();
+
+- checkForUpdate();
+-
+ ChannelAggregator::instance()->start();
+ }
+
diff --git a/media-video/minitube/minitube-2.1.3.ebuild b/media-video/minitube/minitube-2.1.3.ebuild
new file mode 100644
index 000000000000..d236d220c97f
--- /dev/null
+++ b/media-video/minitube/minitube-2.1.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/minitube-2.1.3.ebuild,v 1.1 2013/11/02 12:35:00 hwoarang Exp $
+
+EAPI=5
+PLOCALES="ar ca ca_ES da de_DE el en es es_AR es_ES fi fi_FI fr he_IL hr hu
+ia it jv nl pl pl_PL pt_BR ro ru sk sl tr zh_CN"
+
+inherit l10n qt4-r2
+
+DESCRIPTION="Qt4 YouTube Client"
+HOMEPAGE="http://flavio.tordini.org/minitube"
+# As usual, upstream never releases proper tarballs
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gstreamer kde"
+
+DEPEND=">=dev-qt/qtgui-4.6:4[accessibility,gtkstyle]
+ >=dev-qt/qtdbus-4.6:4
+ kde? ( || ( media-libs/phonon[gstreamer?] >=dev-qt/qtphonon-4.6:4 ) )
+ !kde? ( || ( >=dev-qt/qtphonon-4.6:4 media-libs/phonon[gstreamer?] ) )
+ gstreamer? (
+ media-plugins/gst-plugins-soup:0.10
+ media-plugins/gst-plugins-ffmpeg:0.10
+ media-plugins/gst-plugins-faac:0.10
+ media-plugins/gst-plugins-faad:0.10
+ media-plugins/gst-plugins-theora
+ )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+DOCS="AUTHORS CHANGES TODO"
+
+#455976
+PATCHES=( "${FILESDIR}"/${P}-disable-updates.patch )
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ # Remove unneeded translations
+ local trans=
+ for x in $(l10n_get_locales); do
+ trans+="${x}.ts "
+ done
+ if [[ -n ${trans} ]]; then
+ sed -i -e "/^TRANSLATIONS/s/+=.*/+=${trans}/" locale/locale.pri || die
+ fi
+ # gcc-4.7. Bug #422977. Will probably be fixed
+ # once ubuntu moves to gcc-4.7
+ epatch "${FILESDIR}"/${PN}-1.9-gcc47.patch
+}
+
+src_install() {
+ qt4-r2_src_install
+ newicon images/app.png minitube.png
+}