summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-01-27 19:11:28 +0000
committerCédric Krier <cedk@gentoo.org>2008-01-27 19:11:28 +0000
commit38c3f14cf005fac1122846058e63015c179e70b8 (patch)
tree70014c5ddbfe8c2bce2e279223dc79cb0fb0f986 /net-analyzer/httping
parentalpha/ia64/sparc stable (diff)
downloadgentoo-2-38c3f14cf005fac1122846058e63015c179e70b8.tar.gz
gentoo-2-38c3f14cf005fac1122846058e63015c179e70b8.tar.bz2
gentoo-2-38c3f14cf005fac1122846058e63015c179e70b8.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-analyzer/httping')
-rw-r--r--net-analyzer/httping/ChangeLog7
-rw-r--r--net-analyzer/httping/files/digest-httping-1.2.53
-rw-r--r--net-analyzer/httping/httping-1.2.5.ebuild29
3 files changed, 38 insertions, 1 deletions
diff --git a/net-analyzer/httping/ChangeLog b/net-analyzer/httping/ChangeLog
index 7441bc857726..1287560b2038 100644
--- a/net-analyzer/httping/ChangeLog
+++ b/net-analyzer/httping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/httping
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.39 2008/01/18 18:27:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/ChangeLog,v 1.40 2008/01/27 19:11:27 cedk Exp $
+
+*httping-1.2.5 (27 Jan 2008)
+
+ 27 Jan 2008; Cédric Krier <cedk@gentoo.org> +httping-1.2.5.ebuild:
+ Version bump
18 Jan 2008; Raúl Porcel <armin76@gentoo.org> httping-1.2.4.ebuild:
x86 stable
diff --git a/net-analyzer/httping/files/digest-httping-1.2.5 b/net-analyzer/httping/files/digest-httping-1.2.5
new file mode 100644
index 000000000000..d09354040496
--- /dev/null
+++ b/net-analyzer/httping/files/digest-httping-1.2.5
@@ -0,0 +1,3 @@
+MD5 fdc021ff8d189c5c8561e6384f86056e httping-1.2.5.tgz 13078
+RMD160 8e89fbe7308e4b1d3f4e87b7fae9b10edc273218 httping-1.2.5.tgz 13078
+SHA256 bef1bf37c2330eec4758e5527ef8cf91c4b008dee000b76b02199aaf595bb686 httping-1.2.5.tgz 13078
diff --git a/net-analyzer/httping/httping-1.2.5.ebuild b/net-analyzer/httping/httping-1.2.5.ebuild
new file mode 100644
index 000000000000..a2ed014a300d
--- /dev/null
+++ b/net-analyzer/httping/httping-1.2.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/httping/httping-1.2.5.ebuild,v 1.1 2008/01/27 19:11:27 cedk Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="http protocol ping-like program"
+HOMEPAGE="http://www.vanheusden.com/httping/"
+SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="ssl"
+
+DEPEND=">=sys-libs/ncurses-5
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ local makefile
+ use ssl || makefile="-f Makefile.nossl"
+ emake CC="$(tc-getCC)" ${makefile} || die "emake failed"
+}
+
+src_install() {
+ dobin httping || die "dobin failed"
+ doman httping.1 || die "doman failed"
+ dodoc readme.txt || die "dodoc failed"
+}