summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2012-06-22 20:56:51 +0000
committerMatti Bickel <mabi@gentoo.org>2012-06-22 20:56:51 +0000
commitdb5e6a94d2c4ce10faceb16dc12551815e95afd5 (patch)
tree77e3e201b0d88b4ca9cce90f1df3829c4a722d95 /net-analyzer/nagvis
parentStable for amd64, wrt bug #419473 (diff)
downloadgentoo-2-db5e6a94d2c4ce10faceb16dc12551815e95afd5.tar.gz
gentoo-2-db5e6a94d2c4ce10faceb16dc12551815e95afd5.tar.bz2
gentoo-2-db5e6a94d2c4ce10faceb16dc12551815e95afd5.zip
cut dependency on depend.php.eclass, move to EAPI4
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nagvis')
-rw-r--r--net-analyzer/nagvis/ChangeLog7
-rw-r--r--net-analyzer/nagvis/nagvis-1.4.4-r1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/net-analyzer/nagvis/ChangeLog b/net-analyzer/nagvis/ChangeLog
index 7638bf3c0c4d..c7e9115efdec 100644
--- a/net-analyzer/nagvis/ChangeLog
+++ b/net-analyzer/nagvis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nagvis
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagvis/ChangeLog,v 1.8 2012/02/09 10:43:10 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagvis/ChangeLog,v 1.9 2012/06/22 20:56:51 mabi Exp $
+
+*nagvis-1.4.4-r1 (22 Jun 2012)
+
+ 22 Jun 2012; Matti Bickel <mabi@gentoo.org> +nagvis-1.4.4-r1.ebuild:
+ cut dependency on depend.php.eclass, move to EAPI4
09 Feb 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #85926
diff --git a/net-analyzer/nagvis/nagvis-1.4.4-r1.ebuild b/net-analyzer/nagvis/nagvis-1.4.4-r1.ebuild
new file mode 100644
index 000000000000..05ed01386e86
--- /dev/null
+++ b/net-analyzer/nagvis/nagvis-1.4.4-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagvis/nagvis-1.4.4-r1.ebuild,v 1.1 2012/06/22 20:56:51 mabi Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="NagVis is a visualization addon for the well known network managment system Nagios."
+HOMEPAGE="http://www.nagvis.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="automap"
+
+DEPEND=""
+RDEPEND=">=net-analyzer/ndoutils-1.4_beta4
+ automap? ( >=media-gfx/graphviz-2.14 )
+ virtual/httpd-php
+ dev-lang/php[gd,mysql,unicode]"
+
+src_install() {
+ for docfile in README INSTALL
+ do
+ dodoc ${docfile}
+ rm ${docfile}
+ done
+
+ grep -Rl "/usr/local" "${S}"/* | xargs sed -i s:/usr/local:/usr:g
+
+ dodir /usr/share/nagvis
+ mv "${S}"/{config.php,index.php,nagvis,wui} "${D}"/usr/share/nagvis/
+
+ dodir /var/nagvis
+ dosym /var/nagvis /usr/share/nagvis/var
+ fowners apache:root /var/nagvis
+
+ dodir /etc/nagvis
+ mv "${S}"/etc/* "${D}"/etc/nagvis/
+ dosym /etc/nagvis /usr/share/nagvis/etc
+
+ fperms 664 /etc/nagvis/nagvis.ini.php-sample
+ fperms 775 /etc/nagvis/maps
+ fperms -R 664 /etc/nagvis/maps/
+ fowners -R apache:root /etc/nagvis/maps/
+}
+
+pkg_postinst() {
+ elog "Before running NagVis for the first time, you will need to set up"
+ elog "/etc/nagvis/nagvis.ini.php"
+ elog "A sample is in"
+ elog "/etc/nagvis/nagvis.ini.php-sample"
+}