summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-08-30 04:00:14 +0000
committerJeroen Roovers <jer@gentoo.org>2010-08-30 04:00:14 +0000
commit5970fe9d781a200d7dbf50aa335545cbca4ba4e3 (patch)
tree4769d6f5e77f8436783de7da3b81d92b3805da28 /net-analyzer/p0f
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-5970fe9d781a200d7dbf50aa335545cbca4ba4e3.tar.gz
gentoo-2-5970fe9d781a200d7dbf50aa335545cbca4ba4e3.tar.bz2
gentoo-2-5970fe9d781a200d7dbf50aa335545cbca4ba4e3.zip
Respect LDFLAGS (bug #335184). Call emake just once. Set -j1 because it does not matter. Add comments where needed.
(Portage version: 2.2_rc71/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/p0f')
-rw-r--r--net-analyzer/p0f/ChangeLog8
-rw-r--r--net-analyzer/p0f/p0f-2.0.8-r2.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/net-analyzer/p0f/ChangeLog b/net-analyzer/p0f/ChangeLog
index bc23e0558240..29304efb4938 100644
--- a/net-analyzer/p0f/ChangeLog
+++ b/net-analyzer/p0f/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/p0f
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/ChangeLog,v 1.43 2010/01/01 17:43:16 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/ChangeLog,v 1.44 2010/08/30 04:00:14 jer Exp $
+
+*p0f-2.0.8-r2 (30 Aug 2010)
+
+ 30 Aug 2010; Jeroen Roovers <jer@gentoo.org> +p0f-2.0.8-r2.ebuild:
+ Respect LDFLAGS (bug #335184). Call emake just once. Set -j1 because it
+ does not matter. Add comments where needed.
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org> p0f-2.0.8-r1.ebuild:
Transfer Prefix keywords
diff --git a/net-analyzer/p0f/p0f-2.0.8-r2.ebuild b/net-analyzer/p0f/p0f-2.0.8-r2.ebuild
new file mode 100644
index 000000000000..e901fafe6906
--- /dev/null
+++ b/net-analyzer/p0f/p0f-2.0.8-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.8-r2.ebuild,v 1.1 2010/08/30 04:00:14 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="p0f performs passive OS detection based on SYN packets."
+HOMEPAGE="http://lcamtuf.coredump.cx/p0f.shtml"
+SRC_URI="http://lcamtuf.coredump.cx/p0f/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static"
+
+DEPEND="net-libs/libpcap"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i p0f.c -e 's;#include <net/bpf.h>;;' || die "sed p0f.c"
+
+ # The first script ensures only p0f is built
+ sed -i mk/* \
+ -e 's|^\(all: $(FILE)\).*$|\1|' \
+ -e 's|^CFLAGS.*=.*|CFLAGS += \\|g' \
+ -e '/$(CC).* -o /s|$(CFLAGS)|& $(LDFLAGS)|g' \
+ || die "sed makefiles"
+}
+
+src_compile() {
+ # Set -j1 to supress a warning that would not be useful in this case
+ emake -j1 CC=$(tc-getCC) \
+ $(use static && echo static || echo all) p0fq \
+ || die "emake failed"
+}
+
+src_install () {
+ use static && mv p0f-static p0f
+ dosbin p0f p0frep test/p0fq || die
+
+ insinto /etc/p0f
+ doins p0f.fp p0fa.fp p0fr.fp
+
+ doman p0f.1 || die
+ cd doc
+ dodoc ChangeLog CREDITS KNOWN_BUGS README TODO
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die "newconfd failed"
+ newinitd "${FILESDIR}"/${PN}.initd3 ${PN} || die "newinitd failed"
+}
+
+pkg_postinst(){
+ elog "Adjust /etc/conf.d/p0f to your liking before using the"
+ elog "init script. For more information on options, read man p0f."
+}