summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-07-29 03:09:58 +0000
committerJeroen Roovers <jer@gentoo.org>2009-07-29 03:09:58 +0000
commit6e5bbc918e13c3901829b24c5cb5d3f6bea0eb2e (patch)
tree88f113e2dc164596537e3fff09d78a015f78a1a5 /net-analyzer
parentp.mask net-im/silky for removal, bug 279547 (diff)
downloadgentoo-2-6e5bbc918e13c3901829b24c5cb5d3f6bea0eb2e.tar.gz
gentoo-2-6e5bbc918e13c3901829b24c5cb5d3f6bea0eb2e.tar.bz2
gentoo-2-6e5bbc918e13c3901829b24c5cb5d3f6bea0eb2e.zip
Revision bump to apply >net-libs/gnutls-2.7 patch (bug #279525).
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/echoping/ChangeLog8
-rw-r--r--net-analyzer/echoping/echoping-6.0.2-r1.ebuild66
-rw-r--r--net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch41
3 files changed, 114 insertions, 1 deletions
diff --git a/net-analyzer/echoping/ChangeLog b/net-analyzer/echoping/ChangeLog
index f8b5d5925de3..daf1fb120480 100644
--- a/net-analyzer/echoping/ChangeLog
+++ b/net-analyzer/echoping/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/echoping
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/ChangeLog,v 1.17 2009/07/02 13:21:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/ChangeLog,v 1.18 2009/07/29 03:09:56 jer Exp $
+
+*echoping-6.0.2-r1 (29 Jul 2009)
+
+ 29 Jul 2009; Jeroen Roovers <jer@gentoo.org> +echoping-6.0.2-r1.ebuild,
+ +files/echoping-6.0.2-gnutls.patch:
+ Revision bump to apply >net-libs/gnutls-2.7 patch (bug #279525).
02 Jul 2009; Jeroen Roovers <jer@gentoo.org> echoping-6.0.2.ebuild:
Restrict testing (bug #276210). Fix one grammatical error.
diff --git a/net-analyzer/echoping/echoping-6.0.2-r1.ebuild b/net-analyzer/echoping/echoping-6.0.2-r1.ebuild
new file mode 100644
index 000000000000..d5cfa6b35013
--- /dev/null
+++ b/net-analyzer/echoping/echoping-6.0.2-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/echoping-6.0.2-r1.ebuild,v 1.1 2009/07/29 03:09:56 jer Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="echoping is a small program to test performances of remote servers"
+HOMEPAGE="http://echoping.sourceforge.net/"
+SRC_URI="mirror://sourceforge/echoping/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls http icp idn priority smtp ssl tos postgres ldap"
+RESTRICT="test"
+
+DEPEND="gnutls? ( >=net-libs/gnutls-1.0.17 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ idn? ( net-dns/libidn )
+ postgres? ( virtual/postgresql-server )
+ ldap? ( net-nds/openldap )"
+
+src_prepare() {
+ # bug 279525:
+ epatch "${FILESDIR}/${P}-gnutls.patch"
+ local i
+ for i in . plugins/ plugins/*/; do
+ cd "${i}"
+ eautoreconf
+ cd "${S}"
+ done
+}
+
+src_configure() {
+ local my_ssl_conf
+ if use gnutls; then
+ if use ssl; then
+ ewarn "You've enabled both ssl and gnutls USE flags but ${PN} can"
+ ewarn "not be built with both, see bug #141782. Using gnutls only."
+ fi
+ my_ssl_conf="${myconf} $(use_with gnutls)"
+ elif use ssl; then
+ my_ssl_conf="${myconf} $(use_with ssl)"
+ fi
+
+ econf \
+ --config-cache \
+ --disable-ttcp \
+ ${my_ssl_conf} \
+ $(use_enable http) \
+ $(use_enable icp) \
+ $(use_with idn libidn) \
+ $(use_enable smtp) \
+ $(use_enable tos) \
+ $(use_enable priority) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ # They are not installed by make install
+ dodoc README AUTHORS ChangeLog DETAILS NEWS TODO
+}
diff --git a/net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch b/net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch
new file mode 100644
index 000000000000..b5be2d989776
--- /dev/null
+++ b/net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch
@@ -0,0 +1,41 @@
+Date: 2009-06-30 14:26
+Sender: bortz
+
+The patch by ametzler seems indeed to work (thanks to him). I've committed
+it (r426) and will make a new release soon.
+
+http://sourceforge.net/tracker/index.php?func=detail&aid=2811861&group_id=4581&atid=104581
+
+
+--- trunk/SRC/configure.ac 2009/06/30 14:18:15 425
++++ trunk/SRC/configure.ac 2009/06/30 14:19:07 426
+@@ -92,14 +92,21 @@
+ AC_ARG_WITH(gnutls,
+ [ --with-gnutls[=DIR] SSL/TLS crypt support (needs GNU TLS), the argument DIR should not be necessary],dnl
+ [if test "$withval" != "no"; then
+- AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
+- GNUTLS=1
+- CPPFLAGS="${CPPFLAGS} `libgnutls-config --cflags`"
+- LDFLAGS="${LDFLAGS} `libgnutls-config --libs`"
+- if test "$withval" != "yes"; then
+- GNUTLSROOT=$withval
+- LDFLAGS="${LDFLAGS} -L$GNUTLSROOT/lib"
+- CPPFLAGS="${CPPFLAGS} -I$GNUTLSROOT/include"
++ if test "$withval" = "yes"; then
++ PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.0.0],
++ [
++ echo "GnuTLS found"
++ AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
++ GNUTLS=1
++ CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
++ LIBS="$LIBS $LIBGNUTLS_LIBS"
++ ],)
++ else
++ AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
++ GNUTLS=1
++ GNUTLSROOT=$withval
++ LDFLAGS="${LDFLAGS} -L$GNUTLSROOT/lib -lgnutls"
++ CPPFLAGS="${CPPFLAGS} -I$GNUTLSROOT/include"
+ fi
+ fi],
+ dnl Default: disable it