summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-06-05 08:09:28 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-06-05 08:09:28 +0000
commite5cecb2f1479ad288639d9632d3b2f809460eb8b (patch)
treed28b3a75742320fede1d62602807049e2b88710b /net-dialup
parentRemoved ebuild installing nonstandard binary names. (diff)
downloadgentoo-2-e5cecb2f1479ad288639d9632d3b2f809460eb8b.tar.gz
gentoo-2-e5cecb2f1479ad288639d9632d3b2f809460eb8b.tar.bz2
gentoo-2-e5cecb2f1479ad288639d9632d3b2f809460eb8b.zip
Respect multilib properly
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/accel-ppp/ChangeLog6
-rw-r--r--net-dialup/accel-ppp/accel-ppp-1.7.4.ebuild6
-rw-r--r--net-dialup/accel-ppp/accel-ppp-1.7.9999.ebuild7
3 files changed, 14 insertions, 5 deletions
diff --git a/net-dialup/accel-ppp/ChangeLog b/net-dialup/accel-ppp/ChangeLog
index 522941fbd3ce..4a7d67beaa65 100644
--- a/net-dialup/accel-ppp/ChangeLog
+++ b/net-dialup/accel-ppp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/accel-ppp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/accel-ppp/ChangeLog,v 1.6 2014/06/03 08:08:37 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/accel-ppp/ChangeLog,v 1.7 2014/06/05 08:09:28 pinkbyte Exp $
+
+ 05 Jun 2014; Sergey Popov <pinkbyte@gentoo.org> accel-ppp-1.7.4.ebuild,
+ accel-ppp-1.7.9999.ebuild:
+ Respect multilib properly
*accel-ppp-1.7.4 (03 Jun 2014)
diff --git a/net-dialup/accel-ppp/accel-ppp-1.7.4.ebuild b/net-dialup/accel-ppp/accel-ppp-1.7.4.ebuild
index a9da54310de9..5668de92c2c7 100644
--- a/net-dialup/accel-ppp/accel-ppp-1.7.4.ebuild
+++ b/net-dialup/accel-ppp/accel-ppp-1.7.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/accel-ppp/accel-ppp-1.7.4.ebuild,v 1.1 2014/06/03 08:08:37 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/accel-ppp/accel-ppp-1.7.4.ebuild,v 1.2 2014/06/05 08:09:28 pinkbyte Exp $
EAPI=5
-inherit cmake-utils linux-info
+inherit cmake-utils linux-info multilib
DESCRIPTION="High performance PPTP, PPPoE and L2TP server"
HOMEPAGE="http://accel-ppp.sourceforge.net/"
@@ -38,8 +38,10 @@ src_prepare() {
}
src_configure() {
+ local libdir="$(get_libdir)"
# There must be also dev-libs/tomcrypt (TOMCRYPT) as crypto alternative to OpenSSL
local mycmakeargs=(
+ -DLIB_PATH_SUFFIX="${libdir#lib}"
-DBUILD_DRIVER=FALSE
-DCRYPTO=OPENSSL
$(cmake-utils_use debug MEMDEBUG)
diff --git a/net-dialup/accel-ppp/accel-ppp-1.7.9999.ebuild b/net-dialup/accel-ppp/accel-ppp-1.7.9999.ebuild
index 2c5bd989358c..d5406382aaa7 100644
--- a/net-dialup/accel-ppp/accel-ppp-1.7.9999.ebuild
+++ b/net-dialup/accel-ppp/accel-ppp-1.7.9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/accel-ppp/accel-ppp-1.7.9999.ebuild,v 1.4 2014/06/03 08:08:37 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/accel-ppp/accel-ppp-1.7.9999.ebuild,v 1.5 2014/06/05 08:09:28 pinkbyte Exp $
EAPI=5
EGIT_REPO_URI="git://accel-ppp.git.sourceforge.net/gitroot/accel-ppp/accel-ppp"
EGIT_BRANCH="1.7"
-inherit cmake-utils git-r3 linux-info
+inherit cmake-utils git-r3 linux-info multilib
DESCRIPTION="High performance PPTP, PPPoE and L2TP server"
HOMEPAGE="http://accel-ppp.sourceforge.net/"
@@ -32,6 +32,7 @@ src_prepare() {
-e "/echo/d" \
-e "s: RENAME accel-ppp.conf.dist::" accel-pppd/CMakeLists.txt || die 'sed on accel-pppd/CMakeLists.txt failed'
+ # TBF shaper is obsolete by upstream, so it's disabled
sed -i -e '/IF (SHAPER)/s/SHAPER/SHAPER_TBF/' \
accel-pppd/extra/CMakeLists.txt || die 'sed on accel-pppd/extra/CMakeLists.txt failed'
@@ -39,8 +40,10 @@ src_prepare() {
}
src_configure() {
+ local libdir="$(get_libdir)"
# There must be also dev-libs/tomcrypt (TOMCRYPT) as crypto alternative to OpenSSL
local mycmakeargs=(
+ -DLIB_PATH_SUFFIX="${libdir#lib}"
-DBUILD_DRIVER=FALSE
-DCRYPTO=OPENSSL
$(cmake-utils_use debug MEMDEBUG)