summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2008-07-09 21:44:58 +0000
committerPatrick McLean <chutzpah@gentoo.org>2008-07-09 21:44:58 +0000
commitb6364444f5a2edeb07a5d7f5b7b1bfda1bdab617 (patch)
tree32f8861b55d58a6ac4c21db843d1b6bd889aa781 /net-dns/dnsmasq
parentFixup for gcc-4.3, bug #230898. Thank you very much to Marek Miller <mlm@shel... (diff)
downloadgentoo-2-b6364444f5a2edeb07a5d7f5b7b1bfda1bdab617.tar.gz
gentoo-2-b6364444f5a2edeb07a5d7f5b7b1bfda1bdab617.tar.bz2
gentoo-2-b6364444f5a2edeb07a5d7f5b7b1bfda1bdab617.zip
Version bump, has theoretical fix for bug #231282
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'net-dns/dnsmasq')
-rw-r--r--net-dns/dnsmasq/ChangeLog8
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.43_rc3.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/net-dns/dnsmasq/ChangeLog b/net-dns/dnsmasq/ChangeLog
index 293971aa0dca..f98a6fb8996f 100644
--- a/net-dns/dnsmasq/ChangeLog
+++ b/net-dns/dnsmasq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/dnsmasq
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.154 2008/07/05 19:07:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.155 2008/07/09 21:44:58 chutzpah Exp $
+
+*dnsmasq-2.43_rc3 (09 Jul 2008)
+
+ 09 Jul 2008; Patrick McLean <chutzpah@gentoo.org>
+ +dnsmasq-2.43_rc3.ebuild:
+ Version bump, has theoretical fix for bug #231282
05 Jul 2008; Raúl Porcel <armin76@gentoo.org> dnsmasq-2.42.ebuild:
alpha/ia64/sparc/x86 stable
diff --git a/net-dns/dnsmasq/dnsmasq-2.43_rc3.ebuild b/net-dns/dnsmasq/dnsmasq-2.43_rc3.ebuild
new file mode 100644
index 000000000000..ae6a08a831bc
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.43_rc3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.43_rc3.ebuild,v 1.1 2008/07/09 21:44:58 chutzpah Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+#SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.gz"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/release-candidates/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="dbus ipv6 isc tftp"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dbus? ( sys-apps/dbus )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i '/^AWK/s:nawk:gawk:' Makefile #214865
+ # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
+ epatch "${FILESDIR}/${PN}-fbsd-config.patch"
+}
+
+src_compile() {
+ use tftp || append-flags -DNO_TFTP
+ use ipv6 || append-flags -DNO_IPV6
+ use isc && append-flags -DHAVE_ISC_READER
+ use dbus && sed -i '$ a #define HAVE_DBUS' src/config.h
+
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="${D}" \
+ install || die
+
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init dnsmasq
+ newconfd "${FILESDIR}"/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+
+ if use dbus ; then
+ insinto /etc/dbus-1/system.d
+ doins dbus/dnsmasq.conf
+ fi
+}