summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-12-02 19:59:52 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-12-02 19:59:52 +0000
commitd7318fbe6d11b690803876bcb7ab74ea45e840f5 (patch)
tree641fe519e2f6aa6e2be66a9bc4c31bacade564f3 /net-im
parentFix leaking issues (diff)
downloadgentoo-2-d7318fbe6d11b690803876bcb7ab74ea45e840f5.tar.gz
gentoo-2-d7318fbe6d11b690803876bcb7ab74ea45e840f5.tar.bz2
gentoo-2-d7318fbe6d11b690803876bcb7ab74ea45e840f5.zip
Fix leaking issues
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/ChangeLog9
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.74-r12
-rw-r--r--net-im/gaim/files/gaim-0.74-log_free.patch51
-rw-r--r--net-im/gaim/gaim-0.74-r1.ebuild110
5 files changed, 173 insertions, 3 deletions
diff --git a/net-im/gaim/ChangeLog b/net-im/gaim/ChangeLog
index eaf9aa678abd..d5f4023adf0b 100644
--- a/net-im/gaim/ChangeLog
+++ b/net-im/gaim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/gaim
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.102 2003/11/27 05:56:47 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/ChangeLog,v 1.103 2003/12/02 19:59:47 lostlogic Exp $
+
+*gaim-0.74-r1 (02 Dec 2003)
+
+ 02 Dec 2003; Brandon Low <lostlogic@gentoo.org> gaim-0.74-r1.ebuild,
+ files/gaim-0.74-log_free.patch:
+ Fix an ebuild doing extra work issue
+ Add a patch to stop logging from leaking memory
27 Nov 2003; Luca Barbato <lu_zero@gentoo.org> gaim-0.74.ebuild:
Marked ~ppc
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 3600e3a11174..649508837a58 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,4 +1,4 @@
-MD5 5cde220d4f02f1eef9cabca413aa5313 gaim-0.74-r1.ebuild 3343
+MD5 924e5edbcdd7daa6bbec0ab1e169bdc8 gaim-0.74-r1.ebuild 3368
MD5 bed467c3e7077888cf4fd615c5f47678 gaim-0.67.ebuild 2185
MD5 3dc9c94c6beb41d2314814297ff004ea gaim-0.72-r2.ebuild 3331
MD5 fab79b2ce10b79dec1849c7e899ee07f gaim-0.73.ebuild 2968
@@ -9,7 +9,7 @@ MD5 9319539d29d9fb3908789ccf6026d7db gaim-0.66-r3.ebuild 1991
MD5 9c060fe66488650173c0a493e8744b0a gaim-0.72.ebuild 2508
MD5 1a9b1940485519f26cffa675c833ca7d gaim-0.70-r2.ebuild 2506
MD5 2e550197c15ea558c920079e6ac57e7f gaim-0.74.ebuild 3299
-MD5 4db62ab67e7f761c0fb3ababf9515304 ChangeLog 16874
+MD5 91db305a0b20eeec75781b6727a6b83b ChangeLog 17100
MD5 19b3cafbbe380403d46cccc45a984b80 metadata.xml 481
MD5 0eed93c71111c6031e5f35e10c54e125 files/gaim-0.73_cjk_gtkconv.patch 1128
MD5 5993641de8d56c2c433f252997c3c39c files/digest-gaim-0.67 135
diff --git a/net-im/gaim/files/digest-gaim-0.74-r1 b/net-im/gaim/files/digest-gaim-0.74-r1
new file mode 100644
index 000000000000..4ececc879fff
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.74-r1
@@ -0,0 +1,2 @@
+MD5 9af9287a96acea2b8a8937cfc9122412 gaim-0.74.tar.bz2 3285757
+MD5 89bd43aac89b2358f0445ee8844cf955 gaim-encryption-2.18.tar.gz 320321
diff --git a/net-im/gaim/files/gaim-0.74-log_free.patch b/net-im/gaim/files/gaim-0.74-log_free.patch
new file mode 100644
index 000000000000..d8529f16efda
--- /dev/null
+++ b/net-im/gaim/files/gaim-0.74-log_free.patch
@@ -0,0 +1,51 @@
+Index: plugins/history.c
+===================================================================
+RCS file: /cvsroot/gaim/gaim/plugins/history.c,v
+retrieving revision 1.29
+diff -u -r1.29 history.c
+--- plugins/history.c 30 Nov 2003 04:33:15 -0000 1.29
++++ plugins/history.c 1 Dec 2003 23:09:47 -0000
+@@ -44,8 +44,7 @@
+ while (logs) {
+ GaimLog *log = logs->data;
+ GList *logs2;
+- g_free(log->name);
+- g_free(log);
++ gaim_log_free(log);
+ logs2 = logs->next;
+ g_list_free_1(logs);
+ logs = logs2;
+Index: src/gtklog.c
+===================================================================
+RCS file: /cvsroot/gaim/gaim/src/gtklog.c,v
+retrieving revision 1.9
+diff -u -r1.9 gtklog.c
+--- src/gtklog.c 1 Dec 2003 00:09:48 -0000 1.9
++++ src/gtklog.c 1 Dec 2003 23:09:47 -0000
+@@ -119,8 +119,7 @@
+ while (lv->logs) {
+ GaimLog *log = lv->logs->data;
+ GList *logs2;
+- g_free(log->name);
+- g_free(log);
++ gaim_log_free(log);
+ logs2 = lv->logs->next;
+ g_list_free_1(lv->logs);
+ lv->logs = logs2;
+Index: src/log.c
+===================================================================
+RCS file: /cvsroot/gaim/gaim/src/log.c,v
+retrieving revision 1.69
+diff -u -r1.69 log.c
+--- src/log.c 1 Dec 2003 00:09:48 -0000 1.69
++++ src/log.c 1 Dec 2003 23:09:47 -0000
+@@ -100,8 +100,7 @@
+ GList *logs2 = logs->next;
+ GaimLog *log = (GaimLog*)(logs->data);
+ size += gaim_log_get_size(log);
+- g_free(log->name);
+- g_free(log);
++ gaim_log_free(log);
+ g_list_free_1(logs);
+ logs = logs2;
+ }
diff --git a/net-im/gaim/gaim-0.74-r1.ebuild b/net-im/gaim/gaim-0.74-r1.ebuild
new file mode 100644
index 000000000000..b771e5b65d93
--- /dev/null
+++ b/net-im/gaim/gaim-0.74-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.74-r1.ebuild,v 1.1 2003/12/02 19:59:47 lostlogic Exp $
+
+IUSE="nls perl spell nas ssl mozilla cjk"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=2.18
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/gaim-encryption-${EV}.tar.gz )"
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1
+ >=sys-apps/sed-4.0.0 )
+ mozilla? ( net-www/mozilla )
+ !mozilla? ( dev-libs/nss )
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2 || die
+ cd ${S}
+ epatch ${FILESDIR}/gaim-0.74-log_free.patch
+ use cjk && epatch ${FILESDIR}/gaim-0.74_cjk_gtkconv.patch
+
+ use ssl && {
+ cd ${S}/plugins
+ unpack gaim-encryption-${EV}.tar.gz
+ }
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ if [ `use mozilla` ]; then
+ NSS_LIB=/usr/lib/mozilla
+ NSS_INC=/usr/lib/mozilla/include
+ else
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ fi
+
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+
+ econf ${myconf} || die "Configuration failed"
+ use perl && sed -i -e 's:^\(PERL_MM_PARAMS =.*PREFIX=\)\(.*\):\1'${D}'\2:' plugins/perl/Makefile
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+
+ use ssl && {
+ local myencconf
+ cd ${S}/plugins/gaim-encryption-${EV}
+
+ myencconf="${myencconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myencconf="${myencconf} --with-nss-includes=${NSS_INC}/nss"
+ myencconf="${myencconf} --with-nspr-libs=${NSS_LIB}"
+ myencconf="${myencconf} --with-nss-libs=${NSS_LIB}"
+ econf ${myencconf} || die "Configuration failed for encryption"
+ emake || die "Make failed for encryption"
+ }
+}
+
+src_install() {
+ einstall || die "Install failed"
+ use ssl && {
+ cd ${S}/plugins/gaim-encryption-${EV}
+ einstall || die "Install failed for encryption"
+ cd ${S}
+ }
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+}
+
+pkg_postinst() {
+ if [ `use cjk` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=cjk') to compile with"
+ ewarn "a patch for CJK support. Please be aware that this patch"
+ ewarn "causes problems with skkinput. kinput2 works fine. Details"
+ ewarn "can be found at http://bugs.gentoo.org/show_bug.cgi?id=24657#c23"
+ ewarn
+ fi
+
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net/ )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.org/ or the gaim-encryption project."
+ ewarn
+ fi
+}