summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-14 06:58:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-14 06:58:17 +0000
commitd3bbd223d0a3376d42cd7ae4162756b94bd0d77a (patch)
tree6abc902bd269f819440875fb541ad0430536a4e5 /net-irc/emech
parentBump (diff)
downloadgentoo-2-d3bbd223d0a3376d42cd7ae4162756b94bd0d77a.tar.gz
gentoo-2-d3bbd223d0a3376d42cd7ae4162756b94bd0d77a.tar.bz2
gentoo-2-d3bbd223d0a3376d42cd7ae4162756b94bd0d77a.zip
Bump
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-irc/emech')
-rw-r--r--net-irc/emech/ChangeLog10
-rw-r--r--net-irc/emech/emech-3.0.3.ebuild76
2 files changed, 83 insertions, 3 deletions
diff --git a/net-irc/emech/ChangeLog b/net-irc/emech/ChangeLog
index 1c27db51080a..dd85c57c13a1 100644
--- a/net-irc/emech/ChangeLog
+++ b/net-irc/emech/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/emech
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/emech/ChangeLog,v 1.12 2009/06/06 21:45:19 cla Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/emech/ChangeLog,v 1.13 2014/01/14 06:58:17 patrick Exp $
+
+*emech-3.0.3 (14 Jan 2014)
+
+ 14 Jan 2014; Patrick Lauer <patrick@gentoo.org> +emech-3.0.3.ebuild:
+ Bump
06 Jun 2009; Dawid Węgliński <cla@gentoo.org> emech-3.0.2.ebuild:
Don't specify full path of installed doc files since PORTAGE_COMPRESS comes
@@ -46,4 +51,3 @@
30 Jul 2004; Sven Wegener <swegener@gentoo.org> +metadata.xml,
+emech-2.8.5.1.ebuild:
Initial import, ebuild written by me.
-
diff --git a/net-irc/emech/emech-3.0.3.ebuild b/net-irc/emech/emech-3.0.3.ebuild
new file mode 100644
index 000000000000..ebdfcf11e388
--- /dev/null
+++ b/net-irc/emech/emech-3.0.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/emech/emech-3.0.3.ebuild,v 1.1 2014/01/14 06:58:17 patrick Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="The EnergyMech is a UNIX compatible IRC bot programmed in the C language"
+HOMEPAGE="http://www.energymech.net/"
+SRC_URI="http://www.energymech.net/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug session tcl"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e 's: "help/":"/usr/share/energymech/help/":' \
+ -e 's: "messages/":"/usr/share/energymech/messages/":' \
+ "${S}"/src/config.h.in
+}
+
+src_compile() {
+ ./configure \
+ --with-alias \
+ --with-botnet \
+ --with-bounce \
+ --with-ctcp \
+ --with-dccfile \
+ --with-dynamode \
+ --with-dyncmd \
+ --with-greet \
+ --with-ircd_ext \
+ --with-md5 \
+ --with-newbie \
+ --with-note \
+ --with-notify \
+ --with-rawdns \
+ --with-redirect \
+ --with-seen \
+ --with-stats \
+ --with-telnet \
+ --with-toybox \
+ --with-trivia \
+ --with-uptime \
+ --with-web \
+ --with-wingate \
+ --without-profiling \
+ $(use_with tcl) \
+ $(use_with session) \
+ $(use_with debug) \
+ || die "./configure failed"
+ emake -C src CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin src/energymech || die "dobin failed"
+
+ insinto /usr/share/energymech/help
+ doins help/* || die "doins failed"
+
+ insinto /usr/share/energymech/messages
+ doins messages/*.txt || die "doins failed"
+
+ dodoc sample.* README* TODO VERSIONS CREDITS checkmech || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "You can find a compressed sample config file at"
+ elog "/usr/share/doc/${PF}/"
+ elog
+}