summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-11 19:39:07 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-11 19:39:07 +0000
commit200f1ac871af6419695e67f9444b084fc5ea53de (patch)
tree83cfda24192d4338dc9e497cc4657beb0cf21388 /net-misc/anyremote
parentTransfer Prefix keywords (diff)
downloadgentoo-2-200f1ac871af6419695e67f9444b084fc5ea53de.tar.gz
gentoo-2-200f1ac871af6419695e67f9444b084fc5ea53de.tar.bz2
gentoo-2-200f1ac871af6419695e67f9444b084fc5ea53de.zip
version bump. Fixes bug #300478
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/anyremote')
-rw-r--r--net-misc/anyremote/ChangeLog9
-rw-r--r--net-misc/anyremote/anyremote-5.1.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/net-misc/anyremote/ChangeLog b/net-misc/anyremote/ChangeLog
index 8be588047a95..01e66b1bd1cf 100644
--- a/net-misc/anyremote/ChangeLog
+++ b/net-misc/anyremote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/anyremote
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/anyremote/ChangeLog,v 1.5 2009/12/26 13:25:21 hwoarang Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/anyremote/ChangeLog,v 1.6 2010/01/11 19:39:07 hwoarang Exp $
+
+*anyremote-5.1 (11 Jan 2010)
+
+ 11 Jan 2010; Markos Chandras <hwoarang@gentoo.org> +anyremote-5.1.ebuild:
+ version bump. Fixes bug #300478
*anyremote-5.0-r1 (26 Dec 2009)
diff --git a/net-misc/anyremote/anyremote-5.1.ebuild b/net-misc/anyremote/anyremote-5.1.ebuild
new file mode 100644
index 000000000000..02f12a38c1fa
--- /dev/null
+++ b/net-misc/anyremote/anyremote-5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/anyremote/anyremote-5.1.ebuild,v 1.1 2010/01/11 19:39:07 hwoarang Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="Anyremote provides wireless bluetooth, infrared or cable remote control service"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth dbus"
+
+RDEPEND="bluetooth? ( || ( net-wireless/bluez ( net-wireless/bluez-libs net-wireless/bluez-utils ) ) )
+ dbus? ( sys-apps/dbus )
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ #workaround to badly broken autotools scripts by upstream
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am \
+ || die "failed to fix documentation path"
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}/" $(use_enable bluetooth) $(use_enable dbus)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "install doc failed"
+}