summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2004-09-15 02:26:59 +0000
committerJason Wever <weeve@gentoo.org>2004-09-15 02:26:59 +0000
commit8e53500da2ab1cfacfcd64da1ffef9ffd093cf71 (patch)
tree86983fdaa98a88629ead5a4be174c7633e6f7473 /net-misc/jigdo/jigdo-0.7.1.ebuild
parentregistered glep 22 ppc-macos keyword (diff)
downloadgentoo-2-8e53500da2ab1cfacfcd64da1ffef9ffd093cf71.tar.gz
gentoo-2-8e53500da2ab1cfacfcd64da1ffef9ffd093cf71.tar.bz2
gentoo-2-8e53500da2ab1cfacfcd64da1ffef9ffd093cf71.zip
Version bump, resolves bug #62705. Thanks to Maxim Reznik <reznikmm@front.ru> for the ebuild.
Diffstat (limited to 'net-misc/jigdo/jigdo-0.7.1.ebuild')
-rw-r--r--net-misc/jigdo/jigdo-0.7.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/jigdo/jigdo-0.7.1.ebuild b/net-misc/jigdo/jigdo-0.7.1.ebuild
new file mode 100644
index 000000000000..784a5af529f4
--- /dev/null
+++ b/net-misc/jigdo/jigdo-0.7.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.1.ebuild,v 1.1 2004/09/15 02:26:59 weeve Exp $
+
+inherit eutils
+
+DESCRIPTION="Jigsaw Download, or short jigdo, is a tool designed to ease the distribution of very large files over the internet, for example CD or DVD images."
+HOMEPAGE="http://atterer.net/jigdo/"
+SRC_URI="http://atterer.net/jigdo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+IUSE="gtk nls berkdb libwww"
+
+DEPEND="gtk? ( >=gtk+-2.0.6 )
+ nls? ( sys-devel/gettext )
+ berkdb? ( =sys-libs/db* )
+ libwww? ( >=libwww-5.3.2 )"
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ use gtk && use libwww || myconf="${myconf} --without-gui"
+ use berkdb || myconf="${myconf} --without-libdb"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man ${myconf} \
+ --datadir=/usr/share || die "./configure failed"
+
+ # Patch the Makefile so that when jidgo is installed, jigdo-lite has
+ # the correct path to the debian mirrors file.
+ epatch ${FILESDIR}/makefile.patch
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc COPYING README THANKS VERSION changelog
+ dodoc doc/*.txt
+ dohtml doc/*.html
+}