summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
commitaa6a19ea25bbed130cef956ef1bd6005cd95bd7e (patch)
tree22f7a92ee079fc4d76db2128cc7ee5a31a028184 /net-misc/sitecopy
parentUpdate (diff)
downloadgentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.tar.gz
gentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.tar.bz2
gentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.zip
dependencie, fhs and use fixes
Diffstat (limited to 'net-misc/sitecopy')
-rw-r--r--net-misc/sitecopy/sitecopy-0.10.12.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/net-misc/sitecopy/sitecopy-0.10.12.ebuild b/net-misc/sitecopy/sitecopy-0.10.12.ebuild
index ff3a37f0c0e9..a5cea1adde4f 100644
--- a/net-misc/sitecopy/sitecopy-0.10.12.ebuild
+++ b/net-misc/sitecopy/sitecopy-0.10.12.ebuild
@@ -1,20 +1,26 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/sitecopy-0.10.12.ebuild,v 1.3 2001/02/27 03:06:16 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/sitecopy-0.10.12.ebuild,v 1.4 2001/05/29 17:28:19 achim Exp $
S=${WORKDIR}/${P}
DESCRIPTION="sitecopy is for easily maintaining remote web sites"
SRC_URI="http://www.lyra.org/sitecopy/${P}.tar.gz"
HOMEPAGE="http://www.lyr.org/sitecopy/"
-DEPEND=">=sys-libs/ncurses-5.2
+DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3
- >=gnome-base/libxml-1.8.10"
+ >=gnome-base/libxml-1.8.10
+ ssl? ( dev-libs/openssl-0.9.6 )"
src_compile() {
- cd ${S}
- try ./configure --prefix=/usr --enable-libxml --host=${CHOST}
+ local myconf
+ if [ "`use ssl`" ] ; then
+ myconf="--with-ssl=/usr"
+ else
+ myconf="--without-ssl"
+ fi
+ try ./configure --prefix=/usr --enable-libxml --host=${CHOST} $myconf
try make
}