summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-10 22:12:37 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-10 22:12:37 +0000
commitceed00718151c0c2d0cdd319593fee6a24954ca4 (patch)
treedcb337c2a8b5b36761ebcd9252112c236e401c07 /net-misc/ssvnc
parentversion bump (diff)
downloadgentoo-2-ceed00718151c0c2d0cdd319593fee6a24954ca4.tar.gz
gentoo-2-ceed00718151c0c2d0cdd319593fee6a24954ca4.tar.bz2
gentoo-2-ceed00718151c0c2d0cdd319593fee6a24954ca4.zip
Add more build flags from old imake #299890 by Marcel Pennewiß.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/ssvnc')
-rw-r--r--net-misc/ssvnc/files/Makefile.libvncauth2
-rw-r--r--net-misc/ssvnc/files/Makefile.vncviewer4
2 files changed, 5 insertions, 1 deletions
diff --git a/net-misc/ssvnc/files/Makefile.libvncauth b/net-misc/ssvnc/files/Makefile.libvncauth
index 09406d6fe386..c24ce4663d5d 100644
--- a/net-misc/ssvnc/files/Makefile.libvncauth
+++ b/net-misc/ssvnc/files/Makefile.libvncauth
@@ -3,3 +3,5 @@ CPPFLAGS += -I. -I../include -D_GNU_SOURCE
srcs = $(wildcard *.c)
libvncauth.a: $(srcs:.c=.o)
$(AR) rc $@ $^
+clean:
+ rm -f *.[oa]
diff --git a/net-misc/ssvnc/files/Makefile.vncviewer b/net-misc/ssvnc/files/Makefile.vncviewer
index b6e8ee223ba9..60879b9461a5 100644
--- a/net-misc/ssvnc/files/Makefile.vncviewer
+++ b/net-misc/ssvnc/files/Makefile.vncviewer
@@ -1,6 +1,8 @@
CFLAGS += -fno-strength-reduce -fno-strict-aliasing
CPPFLAGS += -I. -I../include -D_GNU_SOURCE -DMITSHM
-LDLIBS += ../libvncauth/libvncauth.a -lz -ljpeg -lX11 -lXt -lXaw
+LDLIBS += ../libvncauth/libvncauth.a -lz -ljpeg -lXaw -lXmu -lXt -lSM -lICE -lXpm -lXp -lXext -lX11
include Makefile.in
all: vncviewer
vncviewer: $(SRCS:.c=.o)
+clean:
+ rm -f *.[oa] vncviewer