summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-17 00:28:08 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-12-17 00:28:08 +0000
commita2b9d7139904b4dc0598abd1ae20c4bf796507ed (patch)
tree908e50f5269f4dae9a1833ca40af4591281de3c2 /net-misc
parentAlso add 4.7.3 revision of the imap4 protocol regression fix, bug 382411. (diff)
downloadgentoo-2-a2b9d7139904b4dc0598abd1ae20c4bf796507ed.tar.gz
gentoo-2-a2b9d7139904b4dc0598abd1ae20c4bf796507ed.tar.bz2
gentoo-2-a2b9d7139904b4dc0598abd1ae20c4bf796507ed.zip
Version bump. Includes upstream patch to build plugins into the executable to make RDP and SSH usable (bug #394817, thanks to Philipp Reinkemeier for reporting).
(Portage version: 2.2.0_alpha80/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vinagre/ChangeLog10
-rw-r--r--net-misc/vinagre/vinagre-3.2.2.ebuild74
2 files changed, 83 insertions, 1 deletions
diff --git a/net-misc/vinagre/ChangeLog b/net-misc/vinagre/ChangeLog
index 88eee948aaae..9556f2f2aa15 100644
--- a/net-misc/vinagre/ChangeLog
+++ b/net-misc/vinagre/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/vinagre
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.76 2011/11/07 05:04:22 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.77 2011/12/17 00:28:08 tetromino Exp $
+
+*vinagre-3.2.2 (17 Dec 2011)
+
+ 17 Dec 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +vinagre-3.2.2.ebuild:
+ Version bump. Includes upstream patch to build plugins into the executable to
+ make RDP and SSH usable (bug #394817, thanks to Philipp Reinkemeier for
+ reporting).
*vinagre-3.2.1 (07 Nov 2011)
diff --git a/net-misc/vinagre/vinagre-3.2.2.ebuild b/net-misc/vinagre/vinagre-3.2.2.ebuild
new file mode 100644
index 000000000000..4809ee78ec8d
--- /dev/null
+++ b/net-misc/vinagre/vinagre-3.2.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/vinagre-3.2.2.ebuild,v 1.1 2011/12/17 00:28:08 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="VNC Client for the GNOME Desktop"
+HOMEPAGE="http://www.gnome.org/projects/vinagre/"
+SRC_URI="${SRC_URI}
+ http://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}-patches-0.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="avahi +ssh +telepathy test"
+
+# cairo used in vinagre-tab
+# gdk-pixbuf used all over the place
+RDEPEND=">=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.0.3:3
+ >=gnome-base/gnome-keyring-1
+ >=dev-libs/libxml2-2.6.31:2
+ >=net-libs/gtk-vnc-0.4.3[gtk3]
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-themes/gnome-icon-theme
+
+ avahi? ( >=net-dns/avahi-0.6.26[dbus,gtk3] )
+ ssh? ( >=x11-libs/vte-0.20:2.90 )
+ telepathy? (
+ dev-libs/dbus-glib
+ >=net-libs/telepathy-glib-0.11.6 )
+"
+DEPEND="${RDEPEND}
+ dev-lang/vala:0.12
+ gnome-base/gnome-common
+ >=dev-lang/perl-5
+ >=dev-util/pkgconfig-0.16
+ >=dev-util/intltool-0.40
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ >=sys-devel/gettext-0.17
+ test? ( ~app-text/docbook-xml-dtd-4.3 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog ChangeLog.pre-git NEWS README"
+ # Spice support?
+ G2CONF="${G2CONF}
+ VALAC=$(type -p valac-0.12)
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --disable-spice
+ --enable-rdp
+ $(use_with avahi)
+ $(use_enable ssh)
+ $(use_with telepathy)"
+}
+
+src_prepare() {
+ epatch ../patch/*.patch
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Remove its own installation of DOCS that go to $PN instead of $P and aren't ecompressed
+ rm -rf "${ED}"/usr/share/doc/vinagre
+}