summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-02-27 00:23:49 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-02-27 00:23:49 +0000
commit365a5206314f97b3c4ec8ba4603120a6aa9e8415 (patch)
treeb29a523d93c8938c56e92e071fab0250585684f4 /sci-biology/lagan
parentImport from Science overlay, bug 114096 (diff)
downloadgentoo-2-365a5206314f97b3c4ec8ba4603120a6aa9e8415.tar.gz
gentoo-2-365a5206314f97b3c4ec8ba4603120a6aa9e8415.tar.bz2
gentoo-2-365a5206314f97b3c4ec8ba4603120a6aa9e8415.zip
Import from Science overlay
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64)
Diffstat (limited to 'sci-biology/lagan')
-rw-r--r--sci-biology/lagan/ChangeLog13
-rw-r--r--sci-biology/lagan/files/lagan-2.0-gcc4.3.patch23
-rw-r--r--sci-biology/lagan/lagan-2.0.ebuild47
-rw-r--r--sci-biology/lagan/metadata.xml9
4 files changed, 92 insertions, 0 deletions
diff --git a/sci-biology/lagan/ChangeLog b/sci-biology/lagan/ChangeLog
new file mode 100644
index 000000000000..c48f7c0d4655
--- /dev/null
+++ b/sci-biology/lagan/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sci-biology/lagan
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/lagan/ChangeLog,v 1.1 2009/02/27 00:23:49 weaver Exp $
+
+*lagan-2.0 (26 Feb 2009)
+
+ 26 Feb 2009; Andrey Kislyuk <weaver@gentoo.org>
+ +files/lagan-2.0-gcc4.3.patch, +metadata.xml, +lagan-2.0.ebuild:
+ Import from Science overlay
+
+ 04 Feb 2009; weaver <weaver@gentoo.org> ChangeLog:
+ New package sci-biology/lagan, bug 257667
+
diff --git a/sci-biology/lagan/files/lagan-2.0-gcc4.3.patch b/sci-biology/lagan/files/lagan-2.0-gcc4.3.patch
new file mode 100644
index 000000000000..a4b1d6808e2f
--- /dev/null
+++ b/sci-biology/lagan/files/lagan-2.0-gcc4.3.patch
@@ -0,0 +1,23 @@
+diff -durr lagan20-orig/src/glocal/score.cpp lagan20/src/glocal/score.cpp
+--- lagan20-orig/src/glocal/score.cpp 2009-02-04 15:25:57.698333297 +0000
++++ lagan20/src/glocal/score.cpp 2009-02-04 15:27:23.894092890 +0000
+@@ -2,7 +2,7 @@
+ #include<score.h>
+ #include<leftinfluence.h>
+ #include<rightinfluence.h>
+-#include<fstream.h>
++#include<fstream>
+
+ extern vector<class Score*> scoreFunctions[1<<(UPSTRANDBITS+DOWNSTRANDBITS+RELPOSBITS)];
+
+diff -durr lagan20-orig/src/utils/Glue.cpp lagan20/src/utils/Glue.cpp
+--- lagan20-orig/src/utils/Glue.cpp 2009-02-04 15:25:57.702333182 +0000
++++ lagan20/src/utils/Glue.cpp 2009-02-04 15:27:04.190822654 +0000
+@@ -1,6 +1,7 @@
+ #include "MultiSequence.h"
+ #include "SafeVector.h"
+ #include "Output.h"
++#include <string.h>
+ #include <math.h>
+ #include <assert.h>
+ #include <fstream>
diff --git a/sci-biology/lagan/lagan-2.0.ebuild b/sci-biology/lagan/lagan-2.0.ebuild
new file mode 100644
index 000000000000..79049af85ace
--- /dev/null
+++ b/sci-biology/lagan/lagan-2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/lagan/lagan-2.0.ebuild,v 1.1 2009/02/27 00:23:49 weaver Exp $
+
+inherit eutils
+
+MY_PV="20"
+
+DESCRIPTION="LAGAN, Multi-LAGAN, Shuffle-LAGAN, Supermap: Whole-genome multiple alignment of genomic DNA"
+HOMEPAGE="http://lagan.stanford.edu/lagan_web/index.shtml"
+SRC_URI="http://lagan.stanford.edu/lagan_web/lagan${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/lagan${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ sed -i "/use Getopt::Long;/ i use lib \"/usr/share/${PN}/lib\";" "${S}/supermap.pl" || die
+ epatch "${FILESDIR}"/${P}-*.patch
+}
+
+src_install() {
+ dobin lagan.pl slagan.pl mlagan
+ rm lagan.pl slagan.pl utils/Utils.pm
+ dodir /usr/share/${PN}/lib
+ insinto /usr/share/${PN}/lib
+ doins Utils.pm
+ exeinto /usr/share/${PN}/utils
+ doexe utils/*
+ exeinto /usr/share/${PN}
+ doexe *.pl anchors chaos glocal order prolagan
+ insinto /usr/share/${PN}
+ doins *.txt
+ dosym /usr/share/${PN}/supermap.pl /usr/bin/supermap
+ dosym /usr/bin/lagan.pl /usr/bin/lagan
+ dosym /usr/bin/slagan.pl /usr/bin/slagan
+ echo "LAGAN_DIR=\"/usr/share/${PN}\"" > ${S}/99${PN}
+ doenvd "${S}/99${PN}"
+ dodoc Readmes/README.*
+}
diff --git a/sci-biology/lagan/metadata.xml b/sci-biology/lagan/metadata.xml
new file mode 100644
index 000000000000..3302123e5718
--- /dev/null
+++ b/sci-biology/lagan/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <herd>sci-biology</herd>
+</pkgmetadata>