summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-19 22:03:53 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-19 22:03:53 +0000
commit57784963218ad366c230b758d91b85998258e5ad (patch)
tree41c787684ead324e6c30376af46d06d4df5a9f70 /sci-biology/seqan
parentUpdate stable 5.6.22 patches to include the configure fix for openssl-1.0.2 d... (diff)
downloadgentoo-2-57784963218ad366c230b758d91b85998258e5ad.tar.gz
gentoo-2-57784963218ad366c230b758d91b85998258e5ad.tar.bz2
gentoo-2-57784963218ad366c230b758d91b85998258e5ad.zip
Prefix love, #540690; thanks Michael Schubert for the patch
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/seqan')
-rw-r--r--sci-biology/seqan/ChangeLog8
-rw-r--r--sci-biology/seqan/seqan-1.4.2.ebuild16
2 files changed, 13 insertions, 11 deletions
diff --git a/sci-biology/seqan/ChangeLog b/sci-biology/seqan/ChangeLog
index fd7790e70dd1..8061f95ad69e 100644
--- a/sci-biology/seqan/ChangeLog
+++ b/sci-biology/seqan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/seqan
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/seqan/ChangeLog,v 1.7 2014/12/26 13:01:33 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seqan/ChangeLog,v 1.8 2015/02/19 22:03:53 jlec Exp $
+
+ 19 Feb 2015; Justin Lecher <jlec@gentoo.org> seqan-1.4.2.ebuild:
+ Prefix love, #540690; thanks Michael Schubert for the patch
26 Dec 2014; Justin Lecher <jlec@gentoo.org> seqan-1.4.2.ebuild:
Test for SSE4.1 support, #531876
@@ -32,4 +35,3 @@
13 Mar 2013; Justin Lecher <jlec@gentoo.org> +seqan-1.3.1.ebuild,
+metadata.xml:
New addition
-
diff --git a/sci-biology/seqan/seqan-1.4.2.ebuild b/sci-biology/seqan/seqan-1.4.2.ebuild
index bc221ecb2d27..decbacd4b5b4 100644
--- a/sci-biology/seqan/seqan-1.4.2.ebuild
+++ b/sci-biology/seqan/seqan-1.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/seqan/seqan-1.4.2.ebuild,v 1.3 2014/12/26 13:01:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seqan/seqan-1.4.2.ebuild,v 1.4 2015/02/19 22:03:53 jlec Exp $
EAPI=5
@@ -23,8 +23,6 @@ RDEPEND="${PYTHON_DEPS}
sci-biology/samtools"
DEPEND="${RDEPEND}"
-#S="${WORKDIR}"/${P}/cmake
-
PATCHES=(
"${FILESDIR}"/${P}-shared.patch
"${FILESDIR}"/${P}-include.patch
@@ -32,9 +30,11 @@ PATCHES=(
pkg_pretend() {
[[ ${MERGE_TYPE} = "binary" ]] && return 0
- if ! echo "#include <smmintrin.h>" | gcc -E - 2>&1 > /dev/null; then
- ewarn "Need at least SSE4.1 support"
- die "Missing SSE4.1 support"
+ if use amd64; then
+ if ! echo "#include <smmintrin.h>" | gcc -E - 2>&1 > /dev/null; then
+ ewarn "Need at least SSE4.1 support"
+ die "Missing SSE4.1 support"
+ fi
fi
}
@@ -51,7 +51,7 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DZLIB_INCLUDE_DIRS="${EPREFIX}"/usr/include
+ -DBoost_NO_BOOST_CMAKE=ON
)
cmake-utils_src_configure
}