summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2014-09-06 19:37:21 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2014-09-06 19:37:21 +0000
commit7b8ca3128c2a57d3a563c39adf9270dff58cb4ee (patch)
tree577625b4c43c35d27e25944d57cc665986b31e77 /sci-geosciences
parentPass correct parameters regarding libusb to configure, bug 513552 (diff)
downloadgentoo-2-7b8ca3128c2a57d3a563c39adf9270dff58cb4ee.tar.gz
gentoo-2-7b8ca3128c2a57d3a563c39adf9270dff58cb4ee.tar.bz2
gentoo-2-7b8ca3128c2a57d3a563c39adf9270dff58cb4ee.zip
Version bump, cf. bug #483114
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 35488453)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/josm/ChangeLog11
-rw-r--r--sci-geosciences/josm/files/josm-7347-dist-optimized-fix.patch34
-rw-r--r--sci-geosciences/josm/josm-7347.ebuild74
-rw-r--r--sci-geosciences/josm/josm-9999.ebuild4
4 files changed, 119 insertions, 4 deletions
diff --git a/sci-geosciences/josm/ChangeLog b/sci-geosciences/josm/ChangeLog
index c39ab9e2501b..f8a8d0ed13a9 100644
--- a/sci-geosciences/josm/ChangeLog
+++ b/sci-geosciences/josm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/josm
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/josm/ChangeLog,v 1.47 2013/07/17 10:06:32 hanno Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/josm/ChangeLog,v 1.48 2014/09/06 19:37:21 nixphoeni Exp $
+
+*josm-7347 (06 Sep 2014)
+
+ 06 Sep 2014; Joe Sapp <nixphoeni@gentoo.org> +josm-7347.ebuild,
+ +files/josm-7347-dist-optimized-fix.patch:
+ Version bump; thanks to Marcel Pennewiß, Elias Probst, Thomas Beutin, and
+ Jean-Claude Repetto on bug #483114
*josm-6060 (17 Jul 2013)
diff --git a/sci-geosciences/josm/files/josm-7347-dist-optimized-fix.patch b/sci-geosciences/josm/files/josm-7347-dist-optimized-fix.patch
new file mode 100644
index 000000000000..7ad808c9c98d
--- /dev/null
+++ b/sci-geosciences/josm/files/josm-7347-dist-optimized-fix.patch
@@ -0,0 +1,34 @@
+Index: trunk/build.xml
+
+This is the fix for josm bug #7351, which affects Gentoo builds.
+===================================================================
+--- a/trunk/build.xml
++++ b/trunk/build.xml
+@@ -230,6 +230,8 @@
+ <compilerarg value="-Xlint:static"/>
+ <compilerarg value="-Xlint:try"/>
+ <compilerarg value="-Xlint:unchecked"/>
++ <!-- Undocumented argument to ignore "Sun internal proprietary API" warning, see http://stackoverflow.com/a/13862308/2257172 -->
++ <compilerarg value="-XDignore.symbol.file"/>
+ </javac>
+ <copy todir="build" failonerror="no" includeemptydirs="no">
+ <fileset dir="resources"/>
+@@ -419,7 +421,7 @@
+ -keep class JOSM
+ -keep class * extends org.openstreetmap.josm.io.FileImporter
+ -keep class * extends org.openstreetmap.josm.io.FileExporter
+- -keep class org.openstreetmap.josm.data.imagery.types.Adapter1
++ -keep class org.w3._2001.xmlschema.Adapter1
+ -keep class org.openstreetmap.josm.actions.search.SearchCompiler$Never
+
+ -keepclassmembers enum * {
+@@ -432,7 +434,8 @@
+ public protected *;
+ }
+
+- # Disable annoying [proguard] Note: the configuration keeps the entry point '...', but not the descriptor class '...'. This notes should not be a problem as we don't use obfuscation
++ # Disable annoying [proguard] Note: the configuration keeps the entry point '...', but not the descriptor class '...'.
++ # This note should not be a problem as we don't use obfuscation
+ -dontnote
+ </proguard>
+ </target>
diff --git a/sci-geosciences/josm/josm-7347.ebuild b/sci-geosciences/josm/josm-7347.ebuild
new file mode 100644
index 000000000000..ee4a6ce713cc
--- /dev/null
+++ b/sci-geosciences/josm/josm-7347.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/josm/josm-7347.ebuild,v 1.1 2014/09/06 19:37:21 nixphoeni Exp $
+
+EAPI=5
+
+JAVA_ANT_ENCODING=UTF-8
+
+[[ ${PV} == "9999" ]] && SUBVERSION_ECLASS="subversion"
+ESVN_REPO_URI="http://josm.openstreetmap.de/svn/trunk"
+inherit eutils java-pkg-2 java-ant-2 ${SUBVERSION_ECLASS}
+unset SUBVERSION_ECLASS
+
+DESCRIPTION="Java-based editor for the OpenStreetMap project"
+HOMEPAGE="http://josm.openstreetmap.de/"
+# Upstream doesn't provide versioned tarballs, so we'll have to create one on our own:
+# REVISION=${PV}
+# mkdir -p josm-${REVISION}
+# svn co -r ${REVISION} http://josm.openstreetmap.de/svn/trunk/ josm-${REVISION}
+# cd josm-${REVISION} && ant init-svn-revision-xml && cd -
+# tar -cz --exclude=.svn -f /usr/portage/distfiles/josm-${REVISION}.tar.gz josm-${REVISION}
+[[ ${PV} == "9999" ]] || SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == "9999" ]] || \
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/${P}"
+
+IUSE=""
+
+src_prepare() {
+
+ if [[ ${PV} == "9999" ]]; then
+
+ # create-revision needs the compile directory to be a svn directory
+ # see also http://lists.openstreetmap.org/pipermail/dev/2009-March/014182.html
+ sed -i \
+ -e "s:arg[ ]value=\".\":arg value=\"${ESVN_STORE_DIR}\/${PN}\/trunk\":" \
+ build.xml || die "sed failed"
+
+ else
+
+ # Remove dependency on git and svn just for generating a
+ # revision - the tarball should already have REVISION.XML
+ sed -i -e 's:, *init-git-revision-xml::g' \
+ -e '/<exec[ \t].*"svn"[ \t].*/,+5{d;n;}' \
+ -e 's:${svn.info.result}:1:' \
+ build.xml || die "sed failed"
+
+ # Fix for josm bug #10325
+ epatch "${FILESDIR}/${P}-dist-optimized-fix.patch"
+
+ fi
+
+}
+
+src_compile() {
+ eant dist-optimized
+}
+
+src_install() {
+ java-pkg_newjar "dist/${PN}-custom-optimized.jar" "${PN}.jar" || die "java-pkg_newjar failed"
+ java-pkg_dolauncher "${PN}" --jar "${PN}.jar" || die "java-pkg_dolauncher failed"
+
+ newicon images/logo.png josm.png || die "newicon failed"
+ make_desktop_entry "${PN}" "Java OpenStreetMap Editor" josm "Utility;Science;Geoscience"
+}
diff --git a/sci-geosciences/josm/josm-9999.ebuild b/sci-geosciences/josm/josm-9999.ebuild
index 5305765e259a..e794b94a8ab2 100644
--- a/sci-geosciences/josm/josm-9999.ebuild
+++ b/sci-geosciences/josm/josm-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/josm/josm-9999.ebuild,v 1.3 2013/07/17 10:06:32 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/josm/josm-9999.ebuild,v 1.4 2014/09/06 19:37:21 nixphoeni Exp $
EAPI=5